After import, no tracks listed

I have tried importing from VDJ, Rekordbox and Serato. Lexicon claims to have found each database, and takes time to import, but then no tracks are shown when selecting ‘tracks’ after import.

The strange thing is that ‘statistics’ has data. For example, the Serato import stats show 47,737 tracks - but the ‘tracks’ list shows none.

I have also tried drag and drop of tracks to the ‘tracks’ area (as it says you can) but tracks do not appear.

Sounds like maybe there is an error happening silently that causes it not to load any tracks. Can you upload your Lexicon database? From the Help menu. I’ll take a look here

It seems to have been caused by more than one instance of Lexicon running. I discovered a bunch of them in Task Manager. Once I ended them all and re-opened Lexicon, tracks are visible.

Why is that even possible? Shouldn’t Lexicon be checking to see if it’s already running?

Yes it definitely should. It should not be possible to open more than one Lexicon. Although on macOS it may be running multiple, but different Lexicon processes. One of them is the “renderer” process and there is a background process.

Should it happen again, let me know.