Applying a Cue Anchor Template after Auto Generating Cues

After using Lexicon for a while I’ve found that I prefer different mix in / out points than those marked by the auto cue generator.

So I started using the Cue Anchor templates, which provide:

  1. Cues x beats before first Drop cue
  2. Cues x beats before Blend Out Cue

However by using this I don’t get a Breakdown cue set or the second Drop that was previously set with the auto cue generator.

So, what I’m looking to achieve is a three step process:

  1. Run the Auto Cue Generator just for the Breakdown and 2nd Drop cues

  1. Manually create a 1st Drop cue and Blend Out Cue

  2. Run a Cue Anchor template but retain cues from 1)

What seems to be happening is running step 3) ends up deleting the Breakdown and Drop 2 Cue, when I’d like to retain those. When running step 3 the overwrite cue “Overwrite existing cue points” option is unticked in the Generator Template.

I’ve also tried this the other way around, using the Cue Anchor template first, then running the Auto generator for Breakdown and Drop 2 cues with “Overwrite existing cue points” unticked in the Generator Template, but again, this doesn’t generate the Breakdown or Drop cues.

Is there anyway to achieve my desired outcome?


I think you’re almost there, try checking the Breakdown and Drop 2 in the generator template (last screenshot). They’re getting removed because they aren’t enabled there.

Also maybe a suggestion to skip the first step completely and set the breakdown and drop manually, isn’t that only slightly more work but does give you 100% accurate cues? That’s how I would do it in this case.

Thanks Christiaan,

I’ve been a bit of a track buying spree so have a large number of tracks to process, hence preferring some auto generated if we can. I find the breakdown and Drop detection pretty accurate in the vast majority of cases.

I tried again checking the Breakdown and Drop 2 in the generator template, but after running, the auto generated breakdown and drop 2 cues are still deleted, even though Overwrite existing cue points is unchecked.

Are the cue names Breakdown and Drop 2 identical to your custom cue anchor names? And color if you have set one up in the anchors.
If there is a mismatch there, it won’t find the breakdown (or drop 2) and then it can’t set them because as far as LXC knows, they don’t exist.
Maybe a trailing space in either the anchor or cue name?

Yeah, they’re identical, same name, same colour, no spaces

I’d have to check with your library. I won’t have time for a week though, but upload it with description (link this topic) and I’ll respond when I get the time.

Awesome, thanks - much appreciated. Uploaded.

1 Like

I think the problem is that in the Cue Anchors popup, you didn’t select a break anchor.

If I set it up like this

It does work.

Without it, Lexicon doesn’t know which cue to use when trying to match the breakdown.

Not for me :frowning:

As mentioned “I tried again checking the Breakdown and Drop 2 in the generator template, but after running, the auto generated breakdown and drop 2 cues are still deleted, even though Overwrite existing cue points is unchecked.”

Just tried again with Beta 13

  1. Auto generate breakdown 1 and Drop 2 cues

  2. Set another Drop cue, (Drop 1) and a Blend Out cue and reorder

  3. Apply generator template

Break cue and Drop 2 cue have been deleted

What am I missing here?!

Thanks so much!

Can you show a screenshot of your custom cue anchors?

Should look like this

I added the Break one

Ah, so is it here that I need to add the Break and Drop 2?

I have a very similar issue trying to use custom anchors. I have a 3 step process:

  1. Automatically generate the start cue with the first template
  2. Manually set the drop and end anchors
  3. Set additional cue points with a second template

My first template looks like this:

Which will generate cue points that look like this:

My second template looks like this:

Here’s the custom anchors:

And it will generate cue points that look like this:

After running the 2nd template, the start cue point disappears, and I’m missing cue points #6 and #7.

Where is your Outro cue? Maybe the 32/64 beats after that are no inside the track anymore?

I thought that might be the case, but it’s like 16 bars from the end of the track.

In the Edit Custom Anchors popup, can you also enter the name of the anchor? So Drop and Outro in the right fields. Then try again

And are you on the latest Lexicon?

Looks like I figured it out. I also upgraded to the latest beta (not sure if that had an impact).

  • Adding the start cue to the custom anchor list of the 2nd template kept it from being deleted
  • Using a custom anchor other than “end” (I’m using breakdown) fixed the other issue.
1 Like