Beat Grid - Engine DJ

Hi there, I have a Denon Prime Go. I’ve seen various options in lexicon for beat grid syncing- have tried all three.

After recently syncing, all my tracks are locked to the beatgrid by default. Problem is on the Denon Prime Go there is a tiny blue button which allows adjustment to the beat grid waveform incase there is mistakes. This cannot be accessed now and remains permanently locked in all tracks. This was useful as it allowed adjustment where there was mistakes on the beat grid even whilst playing a track. That option has been disabled on the last two updates of lexicon. Previously this wasn’t affected on my Denon Prime Go.

I’ve had look at all three beat grid sync options- they all lock the waveforms of all tracks now… including default…

Can this be fixed?

You can unlock the beatgrids when you sync, did you try that?

Which FW do you have on your Prime Go? I have a Prime 4 that has this issue but it is not Lexicon that caused the issue, i haven’t updated my engine drive and it has stopped working, I think it maybe a Denon Bug

Hi yes I’ve tried the unlock option and re-synced and still the beat grids are locked on my DPG. So not sure…

I have the latest firmware v2.2.0.

Can you try adding a completely new track to Lexicon in a new test playlist and sync that playlist with unlocked grids to your DPG? That will definitely unlock the grids from a Lexicon standpoint, so if they are still locked then I think it is a Denon/Go issue.

Yes ok I will do that and come back to you. Thank you

Hi there, I still have the same issue. Denon Prime Go beat grid editing facility on the device is locked, I’ve created a new playlist with new tracks added and sync’d it with beat grid “unlocked”option to both Engine Dj and to my current USB Flashdrive and it’s not working.

Interestingly, I have a SD card sync’d from a library with previous lexicon firmware which works fine… so not sure if it’s a Denon Prime Go issue… (if that’s makes sense)…

Alright interesting.

Can you send me your Engine Library/Database2/m.db file that is on your Go?
And tell me which track you last added?

You can upload with this link

Hi Christiaan I’ve sent you two databases - the current one where my beat grid editor on the DPG is locked and a another one from previous lexicon firmware where it still works fine. Please look out for these and let me know what the issue is thanks. Kind regards

Thanks, I will take a look tomorrow or the day after and get back to you.

Hi Christiaan any updates with this ?

Not yet sorry. Finding issues on hardware takes a bit longer. I will look at it after the upcoming Lexicon update in a few days.

I am seeing this from a LExicon export side too now, tracks not exported through Lexicon are fine and can be adjusted but anything through Lexicon I can’t adjust on the unit. I have just wiped my Lexicon exported drive and re exporting to check the export again, will let you know how I get on

I have just cleared and set beatgrids to unlock all on Lexicon and the issue does not show on the prime 4, but with default or lock all it is there, this never used to be the case on previous versions, it appears the lock is doing more than it used to

1 Like

How it currently works is this:

Beatgrid locks on “Lock all”:
All tracks that are exported have their grids locked

Beatgrid locks on “Unlock all”:
All tracks that are exported have their grids unlocked

Beatgrid locks on “Default”:
Grids are locked if they were already locked when imported from Engine.
If there is no previous Engine lock information, the grid is locked if there is a beatgrid (analyzed). The grid is unlocked if there is no beatgrid.
It’s like that to prevent Engine from overwriting Lexicon grids but still allows Engine to analyze grids for tracks that have no grid.

But, on previous versions of Lexicon/Prime OS the ‘locked’ tracks were still able to be manipulated on the hardware, ie using edit grid you could adjust the grid position, this however can’t be done with locked tracks.

Mine have always been locked since I started using Lexicon, now they are having to be unlocked and then the Prime hardware re-analyses the track on load, not ideal.

I suspect it is a change in the way the hardware deals with locked tracks but struggling to prove it as you can only roll the hardware back so far, will keep investigating this end

Is this a change in Engine OS?

I’m getting mixed behavior here. One track works as expected with beatgrid locks and unlocks.

The other won’t let me change the grid (nothing happens when I move the wheel) but when I press /2 BPM, the duration jumps to 0:00 and the track immediately goes to the end when I play it. Pressing Reset during grid edit and it goes back to normal, but still won’t let me change the grid (and grid lock is off in the database).

I am not seeing mixed behaviour on mine, I have rolled back to the release version of Engine OS, not on the Beta now to avoid any quirks there. I have only tried to move the grid, not the other functions.

I will try that later, need to plug the SSD back in my pc and lock the tracks again first.

I will try a track locked via Engine Desktop later too, see if the behaviour is the same

Hey all,

I am also seeing this problem running engine 2.2.1 on my SC5000. I did some looking around and found that tracks from LEX into engine seem to be uneditable because something is wacky with the BPM (see screenshot).

With the beat grid unlocked and synced from LEX, I cant change BPM or move the beat grid with the |< and >| (even if it looks like i can in the screenshot) buttons but i can slide it with the < and > buttons. However, I cannot use x2 or /2, or do a +/- on the tempo. This behavior seems to follow to the hardware and not even let me slide the grid with the platter.

So far the only fix for this has been to unlock and re-analyze in Engine, and that’s not ideal.

Screenshot fresh from LEX before engine re-analize:
Screen Shot 2022-06-12 at 4.31.46 PM

Screenshot after re-analize: notice how the tempo is no longer grey:
Screen Shot 2022-06-12 at 4.32.36 PM

I have a feeling this is an engine desktop issue since my backup flash drive that i havent synced to my computer since engine 2.1.0 does not have the same issue. I am going to attempt downgrading engine and then letting the player do a library upgrade to see if the problem follows.