Beat grid shifted when importing to rekordbox6 from Serato (probably .m4a files)

Please report bugs with the following information:
Lexicon version: Ver. 1.1.13
Operating system:Windows 10

Bug Description:

When importing a Serato database and exporting it to Rekordbox6, the beat grid in some files is in the wrong position.

  • After importing with Lexicon from Serato, Beatshift Collection is executed from Utility.
  • The position of the beat grid shown in Lexicon seems to be correct.

I think the beat grid shift in Rekordbox6 is happening with some file formats.

Specifically, there are many lossless .m4a (ALAC) files that have the beat grid shift. (I have not been able to confirm if all of them, but there are many)
I have no problem with .FLAC files.

Screenshots are below.

It would be great if you could tell me how to deal with this.

Where are you M4A files from?
The problem is that M4A files can contain different encoded audio so right now M4A files beatshift correction is set up for M4A files that come from iTunes. If your M4A files come from somewhere else then it could be getting wrong beatshift info.

Thanks for the reply.

The m4a file I’m managing comes from

  • Most imported from CDs using iTunes (Apple lossless audio codec)
  • A few are converted from wav to .m4a (alac) u
    sing foobar2000 and alac decoder.

The iTunes versions used in the import range from old (10 years old) to the latest.

This problem also occurs with recent iTunes imported files.

Thank you in advance for your help.

Do you happen to have any M4A files purchased from iTunes recently? See if they have the same problem.
I can send you one if you don’t have one.

Then we can confirm my earlier theory at least.

Can you please give us sample files so we can verify this?

I would like to output from Lexicon to Recordbox after setting up a beat grid in Serato.

Here is an M4A file that I use to calibrate the beatshifts with

Apologize for delay in reply as it was a holiday in Japan.

Thank you for your your sending.
I checked with the m4a file you provided and did not find the problem. The beat grid was successfully migrated.

This time the file was made with the AAC codec, but the problem seems to occur with the ALAC codec. (That file is made from iTunes CD importing.)
Is there a solution in these cases?

I’m afraid not. Maybe you can re-encode the files from ALAC to AAC? M4A is a container format so it can contain different codecs which is the problem here. I’m not sure there will ever be a good fix for this specific M4A beatshift problem. That’s why I chose to make iTunes M4A’s the priority since a lot of DJs purchase music from there.

OK, Understood.
I am choosing the ALAC codec because of the sound quality, but it turned out not to be good. I would like to modify the beat grid one by one.

Thank you for your support.

The easiest way to modify grids in Lexicon is to set a hotkey to Move marker to current position to correct your grids and then when all your tracks are done, you can run the Quantize cues recipe. That will move your cues so they are spot on the beatgrid. If you only move your grids a little bit, then 1 beat is fine there, otherwise probably 4 beats is good.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.