Beatgrids lost on import

Lexicon version: 0.36
Operating system: Mac

Bug description
Recently switched to Rekordbox. Recently, after getting everything setup correctly in Rekordbox, when I import into Lexicon, vast swaths of my files are missing beatgrids, cue points, or some combination. By no means all, just a bunch. See screenshots:

Process:

  • Import a playlist with all files
  • Merge with existing library
  • Notice files with clearly setup beatgrids in Rekordbox have non in lexicon
  • All files had beatgrids previously in lexicon

See screenshots:



Screenshot

Please add a screenshot for context. If this is about a DJ app, please also add screenshots of the problem in that DJ app.

Does this also happen if you import without merge enabled? You can make a Lexicon backup before trying this so you won’t lose anything

i’ll give it a shot.

EDIT: I am wrong, there are missing beatgrids on a swath of tracks.

So, import full works perfectly. It appears to be related to the playlist / merge combo in some fashion (I used both).

I’ll do some tests there soon

Did you need me to archive anything?

Not yet, I’ll get back to you when I know more

Wasn’t able to reproduce this here.

I can try your RB database here with beatgrids, maybe the same thing will happen. Can you zip and upload this folder: /Users/user/Library/Pioneer/rekordbox

The share folder contains your beatgrids so that’s why I need the full rekordbox folder.

Upload link

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.