Beatgrids off when moving from Traktor -> Rekordbox

Lexicon tells me that it’s running the beatgrid correction automatically, but I’m still seeing a lot of incorrect beatgrids once my collection which I imported from Traktor is exported to Rekordbox. My collection is all mp3 files that I had taken the time to precisely line up with the beats in Traktor but they are not lined up as precisely in Rekordbox after migration. It’s not practical to have to re-beatgrid my entire collection after migrating, so I’m hoping you can advise how to fix this.

Does Lexicon assume that the beatgrid cue marker in Traktor was #1? That’s the default cue that Traktor uses when analyzing, but I always move my “grid” marker to #8 so it’s out of the way. I usually also have a “load” type marker at the same position, typically as #1 since I usually want songs to load at the first beat. I have noticed that when Rekordbox analyzes for Phrase (only), it will add a memory cue at the first beat, which is typically offset a few thousandths from the beatgrid memory cue that was imported from Traktor.


Can you show me two screenshots of the same track in both RB and Traktor? So I can see that beatshift there.

You can turn off the RB first beat cue in the RB preferences.

HI Christian, I’ll spend some more time on it tonight after work and find some good screenshots for you.

In the meantime, I know I can turn off the RB first beat cue in the RB preferences, but I would expect that it would be at the same position as the imported Traktor beatgrid cue mark if the Traktor beatgrid had imported properly. Is that an appropriate assumption? (I play techno, so almost all of my music has clean 4/4 beats.)

Also, how can I recognize in RB if the Traktor beatgrid itself has been imported (and not just the cue marks and metadata indicating bpm)? I have auto-analyze turned off in RB, so if I see the beat markers does that mean the import happened (whether offset or not)?


No, the generated cue that RB places is a new thing. It’s quite odd really because it even places it in a different spot than the beatgrid RB generates itself. So it seems beatgrid unrelated. Can’t say for sure because I don’t know the inner workings, just my experience.

You can’t really see if the beatgrid is imported without analyzing. That’s why it is important to analyze with Beatgrid/BPM disabled, because that would overwrite it. Only use Phrase there.

RB isn’t made with Lexicon in mind so there are some places we need to make do with what we have :slight_smile:

I spent some more time on this tonight. I imported a playlist with 20+ new tracks that had been analyzed in Traktor and carefully checked beatgrids and cue points for every track in both Traktor and Rekordbox, and everything was good.

I think what I was seeing are subtle differences in how the waveforms are rendered in the two apps – Traktor renders the waveforms with a narrower pixel width than RB, and they appear slightly blurry at max zoom in RB. So at a glance last night they looked like they’re slightly off from each other when I think it’s just the difference in how they’re drawn on the screen.

Also, I checked all my imported beat grids in RB vs. the metronome and they’re all right on.

So I think this was a false alarm – basically “user error” :grin:

Anyways, thank you for creating this app. It’s such a massive service to the DJ community. You managed to make a task I had been dreading after my experience with another conversion utility – moving my collection from Traktor to RB so I’m not “locked in” any more – and make it enjoyable. I really feared I’d be having to manually tweak every cue marker in every song to keep them perfect, but thankfully that wasn’t the case. Using Lexicon now, it’s not just a conversion to struggle with, but I can focus on how I want to organize my library!


Yeah waveforms are slightly different in all DJ apps and Lexicon, so the golden rule is to use your ear :slight_smile:

Glad you’re enjoying Lexicon! And don’t hesitate to ask any other questions