Beatport chart - can't find a way to add to cart

Please fill in this bug report template:

Lexicon version: 1.5.4
Operating system (remove one): Mac

Bug description:

According to the changelog, from the charts page I can now directly add tracks to a Beatport cart. But I can’t find any button or right-click menu entry that will let me do anything except preview in Lexicon. The old link to open in Beatport is gone too.

Step by step to reproduce:

Open Lexicon
Click flame icon on left to open charts
Pick a chart
There are only 3 columns in the display: TItle, Artist, unlabeled column containing Play Preview buttons
Right clicking in header of table lets me display album and release date (note: if you leave the charts and come back again, the added columns are not sticky - you have to choose them again)

Nowhere is there an add to cart icon.


I hope you can fix this quickly – shopping beatport via Lexicon is a much better experience than using beatport itself.

Are you logged in to Beatport? On the Beatport page, click “My Cart” and login

I was logged in to beatport on the browser (Chrome) but there’s no ability that I could find in Lexicon to add tracks to my cart on beatport.

I was expecting an “add to cart” button in the Lexicon UI, likely need the “Preview” button for each track on the chart since that’s where the Open in Beatport button used to be.

Yeah the Open button is replaced by the Cart button if you are logged in.

Can you go to the Beatport screen in Lexicon and click the My Cart tab? What does it show there now?

I doublechecked in Chrome and I’m logged in to Beatport there. But when I open up Lexicon, there’s not an “Open” button or a “Cart” button in the Charts tab. Only a “Preview” button, so it seems there’s no way to get to Beatport from the charts page any more.

I found a “enable beta feature” in Lexion settings, checked that box, and restarted Lexicon. When I click the “flame” tab to get to Charts there is still not an “Open” or “Cart” button, so that didn’t fix it.

When I click the new Beatport tab, I get an error that Beatport authorization failed and I need to click the “My Beatport” button to log in again. However, I can’t find a “My Beatport” button anywhere. That screen is stuck on an “Initializing” animation. (Beatport Catalog and My Cart tabs on that screen are grayed out.)

Okay, I understand what you mean now. I’m seeing the same thing happen when the authorization fails.

Here is a workaround:

  1. On the Beatport screen where it is stuck on “initializing” click the green Search button top right

  2. Go to the My Cart tab:
    Screenshot 2023-09-11 at 22.41.38

  3. Authorize Lexicon on Beatport and confirm the popup

ps: the “My Beatport” button was old and does not exist anymore, I’ve changed that text now

Awesome! That worked. Keep up the great work on your app.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.