Comments not loading for flac files

Lexicon version: 1.5.6
Operating system (remove one): Windows 11
Bug description: I have mixed in key results saved in the comments field for all my files (mp3s and flac). In Lexicon the comment field shows this information for my mp3 files but for only ¬50% or fewer of my flac files. I check the source files and they have the info written to their metadata as expected, Lexicon is just not reading this info.

I tried the reload tags option and this doesn’t change anything I also tried reloading again (merging) from Serrato but that also does nothing. It’s quite annoying because I want to use this information to assist my tagging within Lexicon.

Step by step to reproduce: I just loaded a bunch of mp3s and flac files from a serato sync import. These files had already been processed by Mixed in key and had their metadata updated to include key and energy info in the comments field.


Can you upload a few of your FLAC files? Some that work and some that don’t. I’ll take a look

You can upload with this link:

I just uploaded 3 flac files. The Electrosoul System tune loads the key/energy info correctly, the other 2 don’t.

Interestingly Lexicon is reading some comments info, but only the text that comes after the key/comment info that was inserted by mixed in key.

I was also wrong earlier about the proportion of files with issues. Perhaps only ~5% of my flac files load the comments correctly.

This track illustrates the problem:

Comment field is set to what Lexicon loads. Description is what MIK appears to use.

What I can do is fall back to Description if Comment is empty, this is the case for the Seba track. But the Unknown Error track can’t be fixed that way. I would expect MIK to use the Comment field, or to use both Comment and Description with the same value but that’s not the case here. So this is mostly a MIK problem with FLAC tags.

You can check these tags with kid3

Oh thanks for the info!

Ok I’ll clear all my flac comments. Will I need to wait for an update to get the descriptions loaded?

It kinda strange because when I look at the info in windows it shows that the comments contain the mixed in key info. Maybe flac is not so clear in separating comments and description?

ID3 tags are notoriously vague, it’s a wild west of different implementation and ideas. Windows uses Comment or Description, I didn’t check but it doesn’t use both. Windows ID3 tags are not great, just super basic info, I wouldn’t trust those.

I think clearing the Comment and Description tag before using MIK is the best option. You can probably do that quite easily in bulk with mp3tag

So I got it working but there are a few slightly involved steps required I thought I would share.

  1. Open Mp3tag and load the files you want to manage into the database

  2. Select a flac file and go to View->Extended Tags and you will see that there is a field called description. This is not shown by default as a possible column option nor in the left tag entry panel.

  3. Right click on the left side tag panel and select Customize…

  1. We need to add a new field called DESCRIPTION as follows:

  1. Now select all files you want to modify (or just hit Ctrl+A) and the go to the DESCRIPTION field on the left panel and delete the < keep > text. It’s probably a good idea to do the same for the Comment field to make sure all the flac files are clean.

  2. Go to Mixed in Key and analyze all these song. If they have already been analyzed highlight them, right click and select Re-tag Songs.

  3. Voila! All these flac files should now have correct Mixed in Key comments just like you’d expect from the mp3 files.

1 Like

Awesome, thanks for sharing that! Nice job figuring out a way around that quirk

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.