Cues set in Lexicon not sync'ing to Engine DJ

Hi there,

I have been trying to get cue points set in Engine DJ or Lexicon to work reliably as I sync between the two programs.

An example of the issue I am having is this:

  1. Import track into Lexicon. Use Generate Cue Points. Successfully applies those cue points on track in Lexicon.
  2. Add additional custom cue points in Lexicon where the autogenerate didn’t add them.
  3. Sync to Engine DJ; often times the autogenerated cue points show up in Engine DJ, but not the custom ones I added back in Lexicon.

Further, if I set new cue points in Engine DJ and then import those tracks back into Lexicon, the new custom cue points made in Engine DJ do not show back up in Lexicon (but the autogenerated ones make previously in Lexicon, do still show up).

Is there some fundamental setting I am missing?

I reimport track information in Engine to get album art to show up, write new new tags in Lexicon and that works. But Cue points are not transferring back and forth between the two programs if I make custom additions in either program.

Thanks for your help in advance.

Do you re-import after adding cues in Engine? Otherwise Lexicon does not know about changes you make in Engine

Yes I have done a reimport as well from Engine back to Lexicon app. It doesn’t recognize the new cue points I have added.

But more importantly, I’m more interested in ensuring that additional cue points I add in Lexicon are successfully transferred to Engine DJ first because I want to centralize my library and cue management through lexicon.

(Some context: My home set up in Denon based, but I do want the ability to export cues, playlists and tags to RekordBox as well when I know I’ll be DJing at an event or club where Pioneer stuff is always prevalent)

Normally all that should work. What is odd is that auto generated cues show up in Engine, but the manually added ones don’t. There is no difference between them so if one shows up, they should all show up.

Can you make a quick video of that process? Maybe we’re missing something obvious.
Otherwise I’ll have to dig into the databases and see what is going on, that’s the next step.

ok made a quick video of the process. zipped the quicktime file to fit. Hopefully this works!

it looks to me like when you set a loop in Lexicon with a cue point, it moves over to Engine as a loop (as seen on the track itself) but not as a cue point.

It also misses cue points entirely from when set in Lexicon and sync’d with Engine. (see Loop test #2, does’t sync at all).


I had a related problem…
I do all my work in Traktor, then import to Lexicon which seems to work just fine.
Exporting fromLexicon to Rekordbox also fine
To Serato also ok I think.

Then when I tried to export to engine the hotcues show on the waveform preview on the track list but are not active … on another occasion it showed some hotcues BUT when Engine was playing the track and reached this hotcue it gets still like looping a microfraction of the track… sort of a buzzing noise… and the same happens on the decks (SC6000)

I worked around it and I just grabbed the library by importing via engine from Rekordbox and it sort of works but grids are totally recalculated and don’t follow all the previous work…

Any ideias…
I would love to be able to work via traktor and then sync back to Lexicon and from there to all others…

@robtronik the loop will be in the loop section of the track in Engine, did you check there? Cues and loops are separate in Engine.

@ze_migl can you make a new topic with screenshots or a video that shows the issue?

ok, I did no looping cue set to remove that variable. You can see where I have gone back and forth between Engine and Lexicon, just trying to add cue points. They do not sync between the two programs in a reliable manner. Sometimes they do, sometimes they don’t.

Can you view the video to see that happening?

It looks like sync does work properly (LXC to engine) but when you import (engine to LXC) the new cues are not imported? Is that correct?

double checked - smaller video to prove that (now three times, so its a reproducible feature that doesn’t work). So, confirmed!

Okay, thanks! I’ll take a look at that soon. Seems like sync works normally but the re-import in your video is missing the new cues.

Just tried it but it imports the new cues as expected.

Can you send me your Engine Library/Database2/m.db file? Right after adding the cues in Engine and shutting down Engine. I’ll try it with your database here.

Upload link

Sent! thank you for looking into this.


Imported it but your cues from Engine are just there so there’s nothing wrong with the database.

Maybe it is Dropbox related? Try doing this with Dropbox disabled or better on the internal drive.

I was suspecting that it might have something to do with Dropbox as you asked above. I removed the sync with Dropbox capability inside Engine and set the sync to internal drive and tested it, it works now. Which is great.

I believe that my files are still backed up through the Dropbox application management at my OS level, but not through Engine now.

I suppose that is ok (because its more important that I get Lexicon and Engine syncing reliably than anything else).

That being said, I need to explore how to make my playlists, tags setting, etc. always available via a cloud solution if I needed (so, lets say I lost my USB drive(s), or my laptop took a dump before a gig, I could recall everything remotely and put on another USB drive for DJing).

I suspect that is what cloud back up from Lexicon is for, correct?

Yeah you can upload your database with Cloud Database Backup. Then you can install Lexicon anywhere, restore the database and create a USB on that computer.

You can even upload all your music, just in case.

Sorry for the delayed answer.
I am trying to get a playlist to engine from lexicon, and I get these cues which in back don’t seem to be recorded … at this time I do need to get some free time to get a better look and understanding of this problem. But I though I would at least share the screen shots as someone might have experienced the same or the problem might be known / have a simple fix…

On the other hadn I did a playlkst in RB, imported to Lexicon, but if I export to Traktor it needs to analise again … and the hotcues are locked, I mean I always make the ht1 a load in and the rest of the hotcues as grid cues… and this shows up in TRAKTOR as a sort of temporary 8not saved) cues??
But I don’t see any place to set UNLOCK tracks before exporting (sync) the Lexicon Playlist to Traktor…

Cheers and thank you in advanced

I don’t really understand the problem… Really need more info and screenshots

My Bad,
These tracks were already in Lexicon, later I sync’ed them to RB.
In RB I created a playlist (easier and faster to prelisten, preview, and add to a playlist in RB than in Lexicon). Also I was playing with CDJ3000 so I needed to be 100% sure it would work and didn’t have a chance to test it out before arriving at the gig.

Now back home I want this Playlist on all other software, Engine/ Traktor and I would achieve this by syncing the RB Playlist to Lexicon, I figured it would be simple has lexicon already had analised all the tracks…
It imported fine to Lexicon.

Now exporting (sync’ing) to Traktor I get all hotcues as temporary cues, so I need to manually go track by track and not only save them (they are on the correct position though) but also change their type (HT1 to load in , all other to Grid cues)… as far as I understand not all DVS use cue types, so some degree of work ins understandable …
BUT 1st… all track are Locked (maybe they shouldn’t or there should be a choice on the sync process) 2nd cues maybe should default to hitcue and be saved… again this could derive from the fact that they are locked.

Sync’ing to Engine…
Hotcues are close to the spot spot they should be, although the grid isn’t as I left it when preparing my tracks (quite visible on the screen shots for track on deck 2) … Hotcues are all black and also don’t seem to be saved (or is it just the color black that’s throwing me off??) they seem, again, like temporary cues. The fact that the first cue is a AutoGrid also suggests tha engine is disregarding all prior work done ion the tracks for grids / hotcues.

On both exports some covers are not showing as it seems (even if I re-import info in Engine).

Hope this makes it clear now,

Cheers for the patience and any help7 tips you can provide.