Engine OS To RekordBox - Grid and Cue unconfigured

Lexicon version: 1.1.11
Operating system: Windows

Bug description: When I import the engine to rekordbox the grid is unconfigured and so are the cues

Step by step to reproduce:

  1. Import engine os library to lexicon
  2. Sync To RekordBox 6
  3. View music in rekordbox


Have you run the Beatshift Scanner in Lexicon? This should resolve most shift issues, it is in Utility Menu > Other > Beatshift Correction.

You will then need to re-sync your library to RB

Tried using this functionality and the problem remains

Did you sync to RB again after the scan was complete?

You can upload a problematic track with this link and I can check it for you. Please mention the forum link there.

yes, i synced

There are several tracks where this happens.

Wouldn’t it be better to do remote control to see the problem?

Sorry my english

No, I can test the file here with a special program to see the problem first. Remote control is only for the really hard problems :slight_smile:

Just upload one or two of the files, that’s enough.

I already sent an example song for the tests

I leave here several screenshots as it was on each system

I sent another sample song

I leave here several screenshots as it was on each system

The WAV file is correct, as WAVs can’t have a beatshift. I don’t see a shift there either.

The MP3 might not be getting seen by the beatshift scanner. I am seeing a shift there that is not being corrected. The beatshift generally catches 95%+ of the bad tracks so it might be that this track and some others are not getting recognized by the scanner.

Is there any way to fix this problem?

I have other MP3 songs in the same situation

The problem here is that wherever the MP3 came from, it was made with a bad encoder. So if you have other MP3s that come from the exact same place, chances are they have the same problem.

There is a way to prevent this from happening, by re-encoding your files with a more recent encoder and replacing the original file. You can use a tool like dbPoweramp or one of the many other tools that do it.

But you should do that before adding cues because re-encoding may shift them slightly (can be fixed manually in Lexicon with the Shift Cues/grid recipe). Give it a try with a few tracks before doing everything.

I tried using this tool and still the same problem

You have to completely delete a track from Lexicon (or a re-import from your Engine with merge disabled will also do). Then sync to Rekordbox and check the grid.

Check if the cues look good in Lexicon too, because of the possible shift from re-encoding

Did the process and the problem continues

Is it possible to fix this in the program?

I think at the moment there is no fix for these specific MP3 files. They are not found by the beatshift scanner which is rare but sadly sometimes happens.
I don’t know where your files are from, but this will probably only occur from your files that come from the exact same place. You can try it with other files downloaded from a different source.

The source of these files came from soundCloud , and they are available for download.
Thank you for your help

I’m not sure how Soundcloud works exactly but I don’t think they re-encode everything that is uploaded, so maybe these files are from a Soundcloud uploader that is using a program with a bad encoder. That’s all I can think of at the moment.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.