Engine Parent Crates Empty After Export From Lexicon

Please fill in this bug report template:

Lexicon version:
Operating system (remove one): Windows / Mac
Bug description:
Large parent folders are empty in Engine desktop after exporting from Lexicon. In Lexicon they populate all the tracks within the subfolders. It seems to happen to folders with over 4,000 tracks within them.
Step by step to reproduce:
Export from Lexicon to Engine, open engine, click on parent folder with more than 4,000 tracks in it.

I have the same (or a similar) problem. For me, top crates only populate on the very first export on a fresh USB. I wrote something about this here:

I use this function without issues every week, it does seem very odd that you are having this, it must be scenario specific. Is this on Windows or Mac?

Maybe you aren’t waiting long enough in Engine? I’ve noticed it can sometimes take quite some time (minute or so) for the playlist to show all contents and Engine doesn’t show any kind of loading indicator. Try waiting a bit longer, just to be sure

I would agree, I have noticed a delay sometimes when selecting a parent folder, almost the same as viewing a folder on the prime hardware for the first time

I just double-checked and it’s certainly not a delay on loading. After further digging, the songs from the parent folder are not being imported properly from Serato into Lexicon. Thats why they show up empty in engine.

Im on Mac

It’s not for me either. And my understanding is, that it’s probably and engine problem, not a Lexicon problem. It happens to me when I delete crates and re-export my library to a stick.

As a workaround, I delete the database folder (not the music folder) on the USB stick, and then re-export. That is pretty fast, since lexicon doesn’t have to copy the music anymore. You still need to analyze audio in engine if you want fast loading of tracks though, and then reimport track information to get the cover that is not exported by LXC, and then do another lexicon export to reapply the values and mapped fields from LXC.
With this method, I get a clean export every time.

It’s worth noting that I had to delete my local engine libraries on my partition AND on my primary, although this might have been coincidence, as LXC does not look at them during export.

If the problem happens from Serato to Lexicon, it may just simply be that there is a difference between how Serato crates and Lexicon playlists work.

Serato lets you add both tracks and other crates to any crate. So basically a “crate folder” that has sub-crates, can also contain it’s own tracks.

In Lexicon, it’s much simpler. There are playlists that only contain tracks and folders that only contain playlists. Folder cannot contain their tracks so when importing from Serato, that information is lost.

It worked before without issues. Also, the problem is not consistent. One of the crates I am having this problem with doesn’t have smart crates in it. It only seems to happen to creates with large libraries.

Just deleted all my lexicon crates, ran the cleanup tool and reimported serato into lexicon and there is definitely an import issue going on. Here are screenshots that illustrate that the tracks are not mirrored. Im also missing tracks. Check out the recently added order.

Can you confirm for me that the Morning After Dark track in Serato is in the NOVAKS, Fun Hip Hop or Pop Cheese crate? And not only visible if you have the SALOON crate selected

Hey Christiaan,

Morning After Dark is only in the Saloon Crate.

I reordered a ton of crates before my last sync. I just deleted all the lexicon crates before I imported Serato into Lexicon. Would that have something to do with it? Is

Also, can I have the download link to the version of Lexicon that was released after 1.1.20

That worked well last.

You can download any version like this: https://update.rekord.cloud/releases/lexicon/1.1.20/darwin/x64/Install%20Lexicon%201.1.20.dmg (replace 1.1.20 in both places with whichever version you want)

Can you upload your Serato folder? It will be at this spot Music/_Serato_ or if the track is on an external drive, the Serato folder I need will be at the top of that drive.

You can upload directly to me with this link: http://upload.lexicondj.com

1 Like

Just sent it over.

It’s the same problem as the other topic, see Tracks missing in lexicon in some crates - #4 by Christiaan for the workaround

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.