_Foldertracks Crates Being Created after import

Please fill in this bug report template:

Lexicon version: …Latest
Operating system (remove one): Mac

Bug description:
Lexicon is creating a crate/folder called _Foldertracks within all of my crates that contain sub crates. These also show up when exporting.

Step by step to reproduce: Import from Serato


It’s not a bug, please see Serato

Yeah, i am the user that pointed you to this initially.

Its not bad management - Serato automatically populates all the sub tracks into the parent folder.

I spent A LOT of time finding time out for you.

You then created a toggle that will either create this folder or not. Now that lexicon updated, ive lost that functionality…

Forgive my frustration but it isnt fun to beta test while paying monthly.

That’s not how Serato works there.

When you click a “parent crate”, it will show all tracks inside all sub crates. And it will also show tracks that have been added directly inside the parent crate.

There is no way to know which tracks are directly inside the parent crate, hence bad organization. Not your fault, just Serato for ever allowing that idea.

Lexicon creates the _FolderTracks playlist to give you more clarity. You can still click the parent folder in Lexicon for the same results, as it includes all sub-playlists including the _FolderTracks playlist. When you sync to Serato, it will not create a _FolderTracks crate but instead put those tracks back into your parent crate, as they were.

If you want to get rid of _FolderTracks, just delete them in Lexicon and do a full sync to Serato. Problem solved and next imports won’t create _FolderTracks playlists anymore

No…We discussed this in great detail and again, I spent a lot of time discovering this for you previously.

Serato does not just show the tracks in the parent folder. It physically puts them in there. I know this because I previously deleted everything from the parent crate like you suggested. I then made an empty parent crate. After I added the sub crates, all the tracks showed up in the parent crate. When I removed all the sub crates from the parent, all the tracks remained in the parent crate. Here is the link to our thread about this. Stop Auto-created _crate playlists - #7 by djductape

I am also confused because this behavior from Lexicon is new from the last update.

It used to be called _Crate and you created a toggle to stop this.

Now it is back but called _Foldertracks. instead of _crate

I see your workaround but I do not sync to Serato. I only use lexicon to sync from Serato to engine. Can you please bring back the toggle switch to remove this?

Also, where can I download 1.5.10? Everything got much worse after 1.6 and the auto updates.

Downgraded to 1.5.10

Here is the toggle button I am talking about. “create crate folder playlists” I need this unchecked to function properly.

Also, now there are no _Crate crates. Everything populates as it should.

Internally nothing changed except the name. The toggle is gone and is now always enabled. It changed to _FolderTracks so it makes sense when using with VirtualDJ because it has the same behavior but crate is a very Serato naming.

Other users feel the opposite of what you feel, they are missing their tracks in the parent folders and I had to keep explaing what the toggle did. So that’s why I removed the toggle and changed it to be always enabled. For new users, this is a better experience.

As for the Serato crate behavior, what you described is not what I’m seeing. I just tried this:

  1. Make new crate in Serato: crate 1
  2. Add subcrate: crate 2
  3. Drag track from Finder into crate 2
  4. Click crate 1, just to be sure
  5. Delete crate 2
  6. Click crate 1, it’s empty…
  7. Import into Lexicon. Crate 1 isn’t imported because it was empty and didn’t have a .crate file on disk

So for me, this is as expected. If you are seeing something else, I don’t know why

Yes, it looks like the behavior in Serato changed since our discussion on the thread I posted. Now I get the same as you

I still have the issue though. Can you add the toggle back and default it to on? Lexicon is supposed to mirror my Serato when I import. It used to and now it does not. I have over 250 crates and that is a lot of un-necessary _foldertracks crates to delete, every time I sync - especially when it can mirror my Serato perfectly without that option.

Can you just delete them in Lexicon this one time? You can easily search at the top

Then full sync and subsequent imports should not create _FolderTracks anymore

Okay, here is the issue and why i dont understand the current way serato functions.

Last year when i found this issue and you developed the solution, i deleted all my tracks that auto populated from all of my parent crates.

Now they are all back and i havent added a track into any parent crate since, so at some point Serato is adding them. Ill take the time to do this by hand again.

When these tracks end up in a parent folder again, will you help?

Its getting to the point that lexicon causes me more time than it saves me.

I dont think serato did anything and i think that over time serato adds them to the parent crate. Maybe after an update? I dont know.

Well I would say keep an eye on it and if they re-appear for no good reason, then we can look into it again. I can add the toggle back but it’s not what I would prefer to do. But if we know for sure Serato is re-populating the parent crates at an unknown time, then maybe the toggle is needed

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.