Import tag from text bug

Please fill in this bug report template:

Lexicon version: 1.1.18
Operating system: Windows

Bug description:
When I use the recipe “import tags from text”, at first it won’t work. But then if I just re-edit the comment field manually, it works.
It’s like Lexicon doesn’t find any values from the field at first… why?
I tried to “write tags to file” before using the recipe but it won’t work either.

Please note that I’m transforming an old tag system using / instead of #, using recipe “replace”. Is it possible that the recipe doesn’t write properly the new value?

Step by step to reproduce:
Please see my video:

If this is about a DJ app, please also add screenshots of the problem in that DJ app.

Also, when using the field mapper to write Lexicon tags to comment field, it writes tags by alphabetical order… that’s annoying > would it be possible to have the tags written by category? It makes more sense to me not to mix every type of tag (= having all genre tags first, then all mood tags, …)

Thank you

Thanks for reporting this!
Can you upload your database? From the Help menu in Lexicon.
I will take a look and fix it.

Database/logs uploaded :wink:

Thanks for having a look at this.


Ah okay, I see what’s going on. You are importing from the Genre field but your genres don’t have a #. To use the import tags recipes, your genres needs to be in the hashtag format eg #Techno.

The other way to import tags is from the Genre Cleanup page, there you won’t need a #. I do advice cleaning up the genres first though because it is all imported.

Euh… no it’s not imported from the genre, it’s from the comment field > can you see it in my video?

Woops sorry, I saw genres in your library so I went with those, I’ll look again

1 Like

Can you check if the comments that act weird have a space at the end? Looks like that might cause it.

Next version of Lexicon will have this fixed. The workaround for now is to make sure that space is not there.

Yes that’s it!

i’ll check that in the meantime then :wink:

Thank you

1 Like

Hey Christiaan,

Now I’m trying to sync my tags to VDJ but when I sync my playslist mapping tags to comment, it doesn’t seem to work?

Here’s a video:

Am I missing something?

Thank you for your help


Does that happen to all tracks or only some? Did you have VDJ quit when you did the sync?

There might be a setting in VDJ that reads the comment from new files automatically, you can turn that off. And a second sync might also work then.

Otherwise I don’t have any problems with the field mapping here.

You mean this option?

I’ve selected “No” but unfortunately it doesn’t seem to have an effect. I’ve tried with different playlists and tracks but it won’t work… BUT when I tried with a mp3 playlist, it worked !

Is there an issue when mapping tags with streaming files?

I didn’t know there was one but turns out there was after some searching. The streaming tracks that already existed in VDJ were not getting updated. This will be fixed in the next release, probably tomorrow.
Thanks for reporting :slight_smile:

1 Like

Wow… 5 stars support !

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.