Importing Denon engine playlist fails

I’ve recently shuffled my folders round after freeing up some space with lexicon (1500+ duplicates) which worked flawlessly, I deleted my playlists in engine DJ and re-imported everything (because I didn’t know to do a full sync and just synced playlists, Aaaaaanywho, now I have the playlists the way I want them to be in engine but when I try and import them in to lexicon only 5 out of 8 are visible, no matter what I do I cant get it to see 3 of the playlists

Have you tried the Extra option on the Import page?

Yup, theres several hundred playlists and no way of knowing which is current, several instances of the same playlist that have been deleted, I’ve tried cleaning the database in Engine and they are still all there although I only have 5 root playlists in engine, is there a way to totally purge it and start again?

If you have a Lexicon backup with the right playlists then I would go back to that and delete all your Engine Library/Database2 folders, then sync again

Just testing another idea, in the database itself theres an ispersistent field, all the deleted playlists are there, taken out everything thats flagged 0 and restared engine, seems to be ok (all playlists there), going to let it finish populating as it loads, then close it and import with lexicon hopefully with all those extras missing :slight_smile:

Yeah that is also what the Extra option uses to import missing playlists. Let me know how it goes

Worked well manually editing the extra tables out of the database, have restarted though on another pc with a new library (rekordbox with cue points) and have just imported my database from the pc, made quite a few edits in lexicon (removed duplicates/capitalised/cleared junk tags) and then exported the database to a usb stick for enginedj, it seems to have lost all the cure points in the process, do cue points not get trasferred? the cues are showing in rekorbox and then also in lexicon but none are exported with either full or playlist export to the usb.



Cues always get transferred. What kind of tracks are these? Normal tracks or streaming tracks?

You can try deleting the Engine Library/Database2 folder on the USB and then syncing again