Impossible to import from any DJ App

I just recommended Lexicon to a colleague, but he is having trouble importing his library from any DJ application. I tried it myself on his Mac, but I couldn’t import the library either.

I attempted a complete import from both Serato and Rekordbox, as well as just a couple of playlists, but the result was the same in both cases—the progress bar stayed at 0%.

We both have the same Mac model, the M1. I am running the Monterrey operating system, while he has the Ventura version, and Lexicon 1.40

On my own Mac, I have not encountered any issues. I was able to sync everything between Virtual DJ (VDJ), Rekordbox (RB), Engine, and Serato, as I have subscriptions for all of them.

I also checked the permissions on his operating system, but that didn’t solve the problem. However, I did manage to import tracks into the “TRACKS” tab on his Mac. But when I attempted to create a playlist within the software, the right-click menu didn’t appear.

Any clues or suggestions would be greatly appreciated.

Best regards,

When you right clicked, did you hover the mouse over “Playlists” at the top? If so, it’s quite odd that the right click menu doesn’t appear.

Can you ask your friend to upload the logs, from the Help menu? Then I can take a look and see if there is any error or something that stands out

Hello Christian,

I already instructed him to send the log for further analysis.

Regarding the contextual menu issue, I believe it was actually our mistake. The menu appeared to be empty, but I just realized that the contextual menu only works when clicking on the “PLAYLIST” text at the top. I apologize for any confusion caused by my previous message.

I haven’t seen a log uploaded for this issue though, but I’ll let you know when I do

Just got it.

I don’t see anything odd in the logs.
Can you check how large his Serato database file is? It’s this file: Music/_Serato_/database V2

Update: To be honest, I’m not entirely sure what the exact issue was. However, I remotely connected to his Mac and suspect that there might have been a corrupt crate causing the problem. As a solution, I replaced the current crates with the Subcrate folder from the Serato_Backup. After doing this, Lexicon started importing the playlists successfully. It was certainly an unusual case.

Thank you for your time

Okay, glad it’s solved then! Nice one