Lexicon adds files

Sent. Did you get it?

I don’t see it, can you try again?
I have to run now, but I’ll pick this up again tomorrow morning

1 Like

Doing it again.


It’s working as expected here:

Can you try doing a new import and make sure the Merge with current library option is disabled?

So to be sure I am clear. I will be doing a “Full Import” with “Merge with current library” unchecked? Correct?

Done. That time that folder is now correct. I haven’t checked others. But I noticed it still sorted my folders randomly (wrong).

Another thing is that you have the Source drive option set to the J: drive. You only want to do that if you plug that drive into Denon hardware.
If you just use it as an external drive with Engine desktop, then instead select the Engine Desktop option there.

The imported playlists order not being correct is a known issue, I have yet to fix that.

I have the Prime 4, Prime 4+, and Prime Go.
The Prime 4s all have internal SSDs installed inside of them that I clone (so all files match).

The J:\ drive is the drive (external to the laptop) but an SSD installed inside of the Prime 4.

I don’t store ANY MUSIC on my local laptop so “Engine Desktop” will not work since that isn’t where my Engine Library lives. I’ve never experience any corruption on mismatches of data etc. over the past 5+ years.

Christiaan, after spend a couple of hours checking on of my primary playlist folders ALL TRACKS LOOK TO HAVE COPIED OVER! This is weird how so far it looks good now… especially in the primary folders where I work. My guess is that after the dedup, those archived files remained in the Archive even after doing another “Full Import” from the Engine Library which might explain the inconsistency between what was reflected in the Engine Library vs what was reflected in Lexicon. Good thing I’ve been backing up Lexicon databases along the way to test that theory because I’d love to just reload the “Backup with my Dedupped Tracks archived” and not have to go through that process again. I’ll track things for that on that Bug Report.

Thanks again for quickly looking into this… fingers-crossed all tracks came over from Engine Library as they should.

On another note… any idea when the imported playlist issue will get resolved?

I think you misunderstand when to use the desktop Source Drive option. Normally you should only put it on Device/USB when you want to skip Engine desktop altogether, so you don’t even start that program.
If you do start Engine desktop and do things in there like use the sync manager, then you should put the source drive option to Desktop.

About your archive, yeah I think that is what happened because the second import you did was with Merge enabled. So your playlists were populated again but the tracks remained archived.
Proper workflow for deduping goes like this:

  1. Import
  2. Run duplicate scanner and archive tracks
  3. Full Sync (must be full so Lexicon deletes the old tracks from Engine)
  4. Check if everything is good in Engine
  5. Optionally, clean up the archive

I’ll work on the playlist import order in the next few weeks

1 Like

Thank you Christiaan!!!

1 Like

I’ve changed the Engine DJ importer so the order of the playlists should now be correct. This change is in the beta. Can you give that a try and see if that works as expected?

You can download the beta with this link: Download | Lexicon - DJ Library Management