Lexicon cloud download file format? 1693274660

Lexicon version: 1.5.3.
Operating system: Windows

Bug description: Used Cloud to download files, more then half are unsupported file type, (1693274660). Rekordbox of course does not recognize the file, and will not play the audio. Lexicon, however will play the audio and allow most edits and tasks except “Generate Cue Points”.

Step by step to reproduce: I uploaded my entire library to the cloud a minimum 3 weeks ago. I needed to merge several unorganized and very old external hard drives, with my current pc’s internal hard drive, but also lacked the “upfront” space to hold everything before removing duplicates. I was able to upload the entire library, around 100,000 files with no hiccups, notifications, flags, or emails from lexicon. Everything has been working fine for almost 2 months. 2 or 3 days ago, I was able to free up enough duplicates and “broken” files on the drive I wanted them merged too. I deleted the library on my pc, maybe 35k files, and then disconnected the other externals hard drives. When i go back into lexicon, still everything seems fine. I use the tool to start downloading all the files, check in a day later or so and notice the file extension is weird. The music still plays through lexicon as usual, except the cue generation tool now gives me a file not supported failure and response. I also tried testing the sync to rekordbox, and of course it does not recognize the file or even play the audio.


Can you check what the full location of one of those weird files is?

Located on a 2tb wd hd, created new folder when prompted about original file location.

Can you show me the full location of them in Lexicon?

Whoops, yep

Super strange, never seen anything like that before…
Can you upload your Lexicon database & logs? From the Help menu.

Unsure if i did this properly, so i also tagged the upload with the file format in the message.

Audio still plays, and i can make manual changes to the beatgrid, but can not use the generate cue points tool.

Rekordbox does not play the audio at all

I don’t think Lexicon did this but something else. Because in your logs I’m seeing a lot of errors on files like D:/Music/01 GoodVibes/Billy Joel/._Root Beer Rag - Billy Joel - Streetlife Serenade [1974] - Pop.mp3

Notice the ._ which is a mac thing. Which is strange because you use Windows, but it seems Mac was involved at some point?

These are your cloud files:

Seems that Mac has duplicated your files before uploading. Those ._ files are all empty files.

I still don’t know where the weird numbers come from but I really don’t think Lexicon did that because I can’t think of any way that happened

Thank you for your continued assistance. However, as mentioned in my initial post, " I was able to free up enough duplicates and “broken” files on the drive I wanted them merged too.". I am not interested in the duplicates, and i have those backed up on drives. Roughly 49k files share this weird file extension, when they were originally either mp3, .wav, or .m4a, and only a portion of those i have backed up on drives.
I am running 1 last “Find Broken Tracks” tasks, to try and figure out exactly how many files I don’t have backed up.

This is an almost exact replication of what i did the first time to download the library from the cloud to a new folder named DJ Library.

I’ve tried restoring the database i was happy with on aug 20, and i am now using the find broken tracks tool.

Sorry for the messy thread, i will clean it up or delete once my issue is resolved.

Thank you

I can also just delete the ._ files from the cloud storage, so they won’t appear anymore

1 Like

I think I may have figured out what happened, testing now, but i wont be able to update you till tomorrow.

Let me know what happened please, curious

So, I’m still not sure exactly what happened, but. I restored to a database i was last happy with, then used the find broken tracks tool to download the files to a new location. If I’m remembering correctly the only difference this time, I unchecked the include all cloud storage files option. So when it started downloading this time, it only downloaded the missing 50556 files from the database i was happy with, instead of the 100k+ files it downloaded last time.
As for the file format error, i still don’t know how that happened, but as of right now all files in my library are in the proper format and working 100%.

1 Like

Okay, strange but glad you got it all working!

1 Like