RB Direct Write Issues

Please fill in this bug report template:

Lexicon version: …0.3.42
Operating system: Windows / Mac (remove one) Mac OS 12.2.1
DB / Logs uploaded

First time trying direct RB DB write today. Goodbye XML! Starting point was 1272 tracks that I’d previously imported via XML. Change to nearest colour is selected for syn, as previously when using the XML import.

A few observations / bugs:

  1. Loop colours match Lexicon when imported via XML, however all hot cued loops are now imported as Orange using direct write. This seems to only affect hot cues. Memory Cue loops are correctly coloured as per Lexicon.

  2. RB won’t display the memory cue colour next to the memory cue text, but only on the waveform for some tracks.

  3. Some tracks are missing all memory cue colours in the memory cue window, but appear in the waveform. These look to be the original XML tracks.

  4. Seems the vast majority of tracks are missing specific memory cue colours in the memory cue window, e.g “Mix Odd” “Mix48” “Mix 64” and “Hazard”, these don’t have a cue colour in RB’s memory cue window, but they do on the waveform. Other cues are fine for the same track. In almost all tracks “Mix 32”’ colour shows in the memory cue window, but I’ve come across one that also don’t.

  5. Several tracks, e.g. “Matsu” - the previewed memory cue colours are different than shown in the memory cue window. In this example see Mem Cue “C”.

  6. A couple of track’s cues did not transfer. One of these has an unusual character in the title: Kvål, which shows up as a chinese character in RB. I tried changing the “å” to “a” and writing the track title to the tag and re-syncing, but RB still won’t load the cues for this track. The other track “Lana One” also doesn’t show cues, but can’t see any unusual characters in this one.

  7. Rekordbox has duplicated all tracks that were previously in the collection. I have one version that was previously imported via XML that shows the RB waveform, cues etc. These tracks had analysis lock set in RB. The other, new version (imported via direct write) does not show the waveform or cues in preview and I can’t analyse the track in RB to generate the waveform (stays at 0%) I usually analyse without BPM / Key, to preserve the work done in Lexicon. Auto analysis was enabled. The only way I’ve found to get RB to fully recognise the new tracks is to load it onto a deck at which point it will analyse and the waveform will show up with the cues. Now repeat 1000+ times for all tracks… Was I doing something wrong? Was I supposed to delete all tracks from the collection previously imported via XML first, before attempting a direct write? In the future, do I need to delete all RB playlists prior to syncing from Lexicon?

  8. Looking to see how I can use MyTags now in RB. I can’t seem to select a Lexicon tag in RB’s “MyTag Configuration Window” using the tickbox, nor using the track filter view, so so far I haven’t been able to make use of Lexicon tags to search for tracks in RB. What am I missing here?

  9. After deselecting Lexicon tags using the track filter view, the tags are still selected in the RB’s “MyTag Configuration Window” with the tickbox.

  10. Can’t export 99% of tracks to USB using export folder (containing playlists of local tracks). [4] - Track analysis data is corrupted or doesn’t exist. See attached log. Suspect this is because RB wont allow me to analyse any file i’ve synced from Lexicon at the moment. I’ve tried analysing all tracks for Phrase, which works, so RekordBox should have analysis data for all local tracks, but still fails to export to USB.

  11. Using RB’s Link mode first crashed RB. I was also exporting to USB at the same time. Not sure if this is related. The 2nd time I tried RB’s Link to connect to my XDJ-XZ it seems to work. New tracks are loading and cues are in place. (I wasn’t exporting to USB this time.) Then tried a 3rd time whilst exporting to USB and RB crashed again, so suspect this is an RB issue. Stopped trying to do two things at once and was able to use all tracks via Link successfully on the controller. All cues on the controller screen are now the correct colour, except loops which are still Orange?!

Export Log 2022-03-05.txt (687.6 KB)


  1. Artist is missing from track data for about half the tracks

Do you still have the Rekordbox database with duplicated tracks? If so, can you upload it?

Cue colors should be fixed in the next release.
Mytags should also be fixed.

6, 7 & 11: Was unable to reproduce this, try again in the next release.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.