Serato DJ library import - custom comments not imported

Hi all,

I’ve just started using Lexicon as I found that the cleanup options seemed like they will (finally!) help me get things done faster. I did a first attempt and realised that the custom tags I had already added in the “comments” field of serato don’t seem to correctly upload onto Lexicon.

I’m using this field to tag all my songs with specific custom tags that help me in my workflow during a set, and losing all that work would be a huge bummer. Is there anything that i’m missing here?

Out of the few thousands of songs where i added custom tags, only 16 seem to have imported the “comments” from Serato DJ

Thanks a lot for your help !

Lexicon should just import anything from your comments. What kind of file types do you have? MP3 or something else?

Hi Christiaan,

Thanks for your quick response!

Most files I have are mp3, some are m4a

I can’t seem to find the logic in why some tags are being imported (very few) and others not. I’ve deleted everything out of Lexicon and done the full library import again and it’s the same issue.

Lexicon reads the comment from the ID3 tags, but ID3 tags are very vague, so it could be Lexicon is reading another (invisible) comment ID3 tag than what you have.

Can you upload a few of your mp3s? You can upload with this link:

I have sent a few files where the comments weren’t imported and another separate upload of 1 song where the comments were imported as intended

If this particular issue is resolved, it would make Lexicon everything I ever dreamt of when it comes to library management :slight_smile:

It would appear that the songs where the comments were successfully imported are . aif formatted

I don’t see any comments on any of the files. Can you send a screenshot of your Serato comments?

Also, I’m checking with kid3, so maybe check your files with it and see if that makes sense to you.

Hi Christiaan,

I’m experiencing the weirdest issues.

Since you told me you couldn’t see the tags either, I tried a few things in order to troubleshoot the issue.

I took a few files and created a playlist (crate) in Serato, to ensure I was always dealing with the same songs from one software to another

Here’s the screen shot of what my Serato Library looks like with the comments.

When importing this same list of songs in Lexicon, I don’t see any of the comments, so I also tried within MetaBliss (a standalone software by Mixed In Key, discontinued), allowing to update tags and globally replace certain info), and to my surprise, the comments weren’t visible either, except for 1 song:

So I tried to see if it was the “comment” field that was posing issues, and copy pasted all the info from the Comment field into the “Grouping” field (I did this within Serato DJ). I then uploaded again in MetaBliss and the custom tags were now visible in both the Comment & Grouping columns.

I uploaded these songs in Lexicon and the tags are now visible for that specific set of songs as well, in both grouping and comments columns.

To see if my findings were conclusive, I tried with another set of songs and manually edited the comments in Serato DJ once more and stopped halfway through, as you can see below, the songs for which I manually edited the tags again (just double clicked on the field, copy + pasted the text that was already there), the tags are now also visible in Lexicon for the songs where I did this specific manipulation.

I think I can safely assume that the issue is with Serato not properly saving the tags for some reason, and not with Lexicon. I’m now editing all my songs at once, using a field I don’t use for anything. It’s now updating 18k songs at once, so it might take a while, but i’m pretty sure that Lexicon will now show the custom tags as intended once this is done and I have uploaded the library in Lexicon.

Thanks a lot for your support, and apologies for wasting your time as Lexicon wasn’t the issue here. Hopefully this thread can help anyone having similar issues in the future.

Chris Massiv

Yeah quite an odd issue, sounds like Serato is saving the info to the database file but not each mp3 file. Seems like it skipped doing it that time on your comments. Odd but good to have figured that out, nice job :slight_smile: