Start cue point change/ loop doesn´t work after synch back to Engine DJ

Hi guys,
after I reported 2 days ago an issue with synching from Lexikon to Engine DJ I found another issue.

The cue points where the song starts has changed and this influence also the loop function.

  1. normal behavior in Engine DJ:
    I create an loop in Engine DJ (here seen in yellow)

You can see it´s at the first hot cue and named “16” and starts at the 9th tact (small 9 can be seen on the lower area)

Now I click the “cue” button and the tact number is set to 1. Means now when I load the track it will not start at the beginning of the track, it will starts directly at the loop position.


Now load the track to the media player (in Engine DJ or in my SC6000).

If I trigger now the loop by push the loop button the loop will be highlighted and I can push the “cue” or “play” button. The loop will play and stays activated.

Here a short video. You can see the loop stays activated after I push the “cue” button (the grey highlighted area on the right side stays highlighted)

2 .actual bevaviour after synch:

After I have synched from Lexicon back to EDJ the cue start point has moved again to the start of the song.

If I move now the start point again at the beginning of the loop the loop will NOT stay activated. I need to trigger it all the time again (you can see in the video on the right side the grey highlighted area is gone if I press the “cue” button.

  1. how to solve this issue:

-for each track I have to set manually the cue start point new
-delete the loop and create it new

So it seems like that Lexicon overwrites my cue start points and also moves the grid slightly and that doesn´t let my loops activated.

I hope I explained it well :wink:

Can this be fixed?


Hi! Thanks for the detailed report. The videos really help!

My loops seem to work normally here so it might be specific to your track.
Can you upload your Lexicon database, from the Help menu?
And upload the track that you made your videos for as well? You can use this link to upload directly to me.

I’ll test your database with your track. If I can reproduce the problem here then i can fix it :slight_smile:

90% of the tracks are affected.
It’s affecting the tracks where Lexicon seems to shift the grid just slightly. Now the loop position isn’t match with the actual grid position. Means the loop can’t be triggered correctly.
I tried shifting the grid manually on one track and it helped.

For some tracks when I upload them the first time in EDJ I manually adjust the grid before set the cues and loops.
Could be a reason why not all tracks are affected.

What you can try:
-select a track in EDJ
-Move the grid manually just slightly to the left or right
-set cues and loops
-synch to Lexicon
-synch back to EDJ

This should reproduce the issue if my thesis is correct.

I have sent you 2 files where the loop doesn´t stay active

I have sent you 2 more files where it still works

Database was send as well

I think this happens when loops aren’t perfectly on the beatgrid. Engine always puts them exactly on the grid, but in Lexicon you can place them anywhere.

Can you run the Quantize cues (1 beat) recipe on the bad tracks and see how the loops act in Engine after that?

I don’t touch the beatgrids in Lexicon at all.
It seems Lexicon doesn’t put the grids exactly as Engine does and this causes the issue if you synch back to Engine.

Yeah but can you test the recipe? I need to know if that fixes it for you

I will try run this sequence as you suggested today afternoon.

1 Like

So I did try the quantize cues recipe.
23 out of 38 tracks are still affected with this issue.

Can´t really figure out why.

And still the whole library is affected bz the issue that my start cue point is moved back to the start of the song.

So 23 of 38 are still bad? But for the other 15 it did fix it?

Yes. 23 are bad.

I have created for around 250 tracks the loops new.
So all loops worked.

Synch to Lexicon complete library,
quantize cues for 38 tracks,
synch back to EDJ

23 tracks loops not ok
15 tracks loop work

Okay, thanks for testing that. I’ll try and figure out why it’s happening and see if I can automatically fix it

1 Like

If you need anything further for testing let me know

I found out that if you turn Off the Cue/loop quantization in the Engine settings, the loop will work normally.

It’s because when you start the loop, Engine will jump to the nearest beatgrid marker (quantize) and if that marker falls outside the loop, it will immediately end the loop. If the nearest marker falls inside the loop, it acts normally.

Technically this would be the right solution since Lexicon supports loops anywhere. But I think if a loop in Lexicon is put exactly (or almost exactly, without quantize) on the beatgrid then the loop should still act normally. So I’ll look into that further.

Ok, I will do some testing with that today evening.
I’ll give you feedback

turn off the quantization in EDJ didn´t change anything for me. Still doesn´t work.

Did you mean in the settings of the EDJ or in the media player?

Interesting is that the track UUUU which I have sent you couple of days ago and was one of the examples which didn´t work is fine now after the last synch I did 2 days ago…

Still can´t figure out why.

Btw the problem with the cue start position is reseting itself after synch, is there any fix soon?

Both issues could be solved if Lexicon wouldn´t touch the beatgrid and cue start point. Then this wouldn´t happen I assume.

I saw there is a box in the import settings where you can untick the beatgrid and cue points. Is this the solution?

I haven’t looked at the issue with the cue start changing. There is also a setting for that in Engine, maybe that helps?

When I turned off Cue/loop quantization setting, it completely fixed the issue for me though