Stop Auto-created _crate playlists

Is there a way to prevent the “_Crate” that is being automatically created after importing from Serato? I believe its created because I have nested crates. I do not have tracks placed in the parent crates. Only the sub-crates.

It only creates those when you have tracks directly in those parent crates, otherwise they should not appear.

Are you sure you don’t have any tracks in your parent crates? How many tracks are you seeing your the _crate playlists?

I am positive. I spent quite a bit of time clearing the parent folders and creating a new structures as you directed. The _crate shows up in every crate that has nested/child crates. These crates mirror the parent crate.

Maybe Serato is putting tracks in those parent crates, since you can’t really tell if they are in there. I could check your parent crates but I’m sure tracks would still be in there.

Only thing I can think of is to make creating of _crate playlists an option. Might be better anyway

You are correct. Serato seems to be populating all the tracks from the sub crates into the parent crate. Any chance you can make the _crate feature a toggle switch?


Will do. Didn’t know Serato had this behavior and it doesn’t always seem to do it, but apparent something triggers it

I appreciate it. Im on serato 3.03 if that helps at all.


I’d prefer to have everything populate in the crates at levels above the subcrates, as is the behavior in Serato. I’m not sure I’m fully understanding what’s going on here, but I’d like Lexicon behavior to mirror Serato, with parent crates displaying everything that’s a child below it. How does Rekordbox / Virtual DJ consider the higher level crates (do they include contents of subcrates)?

Rekordbox and VDJ show nothing when clicking a playlist folder.

Serato shows tracks directly added inside the parent crate and all subcrates combined.

Lexicon shows all tracks in all sub-playlists combined. So the _crate playlist is a workaround for the above behavior.