Successful sync to Serato doesn't change anything

I imported my Engine DJ tracks and everything looks fine on Lexicon (beatgrid, cue points, etc)

Then I tried Syncing it to Serato and got a successful message:


However when I open Serato, the library is exactly the way it was before, with some old crates and none of the new ones from Engine DJ. What am I missing?

I’m using:
Windows 11
Serato DJ Pro v3.1.1
Lexicon v1.5.10

Oh, and these are the sync settings:

Sounds like you did everything right
Can you upload your Lexicon database & logs? From the Help menu. I’ll take a closer look

Thanks for the quick reply, I just uploaded the database and logs.

Not seeing anything weird in there…
Is your Serato a normal installation or did you change something?

Lexicon uses your Music/_Serato_ folder. You can check if the files there were changed, just to be sure. Normally Serato picks up anything in there.

Ah, I forgot it’s easy to have a “clean” Serato library, so I tried the following:

  1. Moved the _Serato_ folder somewhere else
  2. Started Serato
  3. Serato created a new _Serato_ folder, so we know for sure it is reading the right place

Next, I deleted this newly created folder and ran the sync from Lexicon (I think it allowed me to do it because it believed the database still existed)

This resulted in the same _Serato_ folder being created, however the only content in there is a SmartCrates folder with a Everything.scrate inside. Nothing else was created. At least now we know for sure Lexicon is also writing on the correct place too (and can do it).

I checked and I do have this smart playlist in Engine/Lexicon, I tried deleting this smart playlist and syncing again (after initializing Serato’s DB), this time the SmartCrates folder is empty and Serato doesn’t have anything :frowning:

Anything else I could try?

Also, if it happen to be more convenient for you, I joined on Discord too if you’d like a quicker debugging session.

Tomorrow I probably won’t have much time to debug. Friday I might be able to do it again.

Thanks for your dedication!

What is weird is that you are deleting the Serato folder before the sync. Lexicon should not allow a sync then, because that Serato folder is required. If Lexicon is still syncing, then it appears to be syncing elsewhere. In your earlier logs, it was syncing to Music/_Serato_ which is the default place.

So something weird is going on there.

Discord is better, but I’m off for today now too so no problem to use the forum instead

Meanwhile I decided to give Rekordbox a try and the sync (Direct) was successful there.

I’m done for the day too, I’ll just try reinstalling Serato just in case, maybe even creating a new user on Windows to be as clean of an install as I reasonably can have. If it works I’ll update it here, if not I’ll see when I’ll have time again this week.

Thanks again anyway!`

Edit: tried reinstalling Serato and creating a new Windows user with fresh Serato and Engine DJ libraries. No luck :frowning:

Can you check if the Music/_Serato_/database V2 file has the date modified changed after a sync? And if the Music/_Serato_/Subcrates folder has files that resemble your playlists?

Those are the 2 important things Lexicon changes

Music/_Serato_/database V2 before Lexicon:

Music/_Serato_/Subcrates doesn’t exist before running Lexicon

Music/_Serato_/database V2 after Lexicon:

Music/_Serato_/Subcrates still doesn’t exist after running Lexicon

So the database V2 is not being changed, just read (probably for the backup pre-sync?) and the Subcrates folder is also not created.

Meanwhile I tested it on my desktop (Windows 10) with a fresh install for Serato, Engine and Lexicon and it worked fine.

So it’s something with Windows 11 or the laptop specifically. :frowning:

I did another experiment and at least I have some good news.

I created a Lexicon backup on my laptop, copied it to my desktop, generated the Serato database on my desktop and then copied the Serato database back to the laptop. It seem to work just fine, it’s just very annoying to do it this way, especially if I’m on the road :frowning:

At least I have a workaround that works…

I am also dealing with this issue. I want to remove all my cue points in Serato. I can upload the songs from Serato to Lexicon, and remove the points in Lexicon. But when I sync back to Serato, nothings changes.

I am also using:
Windows 11 (on a laptop)
Serato DJ Pro v3.1.1
Lexicon v1.5.10

However, I don’t have a Windows 10 maching to workaround this issue.

@styro103 That is a different reason. Removing all cues for Serato is not possible because there is a safeguard there to prevent that. In the past, some users have lost all their cues because they dragged their tracks into Lexicon (so no cues loaded) and then synced to Serato, overwriting all cues with no cues. If you want to re-do all your cues, you can do it in Lexicon and sync when there are cues on your tracks again, that will work normally. If you have more questions on that, please make a new topic.

@gdnt It’s very weird, I can’t tell what is going on there. One last thing to is the Lexicon beta version: Download (BETA) | Lexicon - DJ Library Management
Once you have it running, go to the Help menu → Cleanup and choose Interface. That removes a Serato setting and forces it to use the default folder again (which I think it already uses, but might help).

1 Like

No luck :frowning:

However, not sure if it’s relevant, but when I installed the Beta version, the stable one opened when trying to start the beta.

I uninstalled the stable and was able to use the beta.

You likely still had the stable version running.

Can you upload your Lexicon database & logs again?


Can you confirm if C:\Users\windo\Music\_Serato_ is the Serato folder you are using? That is where Lexicon writes everything to

Yes, when I delete this folder and start Serato, it will re-create it and populate it, so for sure this is the folder Serato is using. That’s where I got the created/modified dates from previous messages.

This laptop also doesn’t have any other drives, so no chance (I hope) that Serato would be trying on other drivers.
I saw this happen on my Desktop. For example if my songs are in D:, Serato also seems to create a D:\_Serato_ and reads from both folders.