Sync to Rekordbox 6 Freezing


I am trying to sync my full collection to Rekordbox 6 on Mac but it freezes whenever I try to sync more than a small playlist, or a large proportion of my playlists. I have roughly 17k tracks in my library. It gets stuck usually at 28%, or sometimes other values in the 20s or 30s. It freezes at this % but my computer keeps processing at full power with fans blasting. What’s causing this?

I will upload logs/database.

I’ve tested some workarounds. If I split the collection in half with smartlists:
Tracks titled A-L with roughly 9k tracks it gets stuck at 22%
Tracks titled M-Z with roughly 8k tracks it completes

Is there an A-L track tripping it over?
EDIT: I’ve narrowed it down to a track title starting with I tripping over the sync. Every other track title letter works.

1 Like

Thanks for reporting that.
I checked your database and there appear to be 2 tracks in there with an invalid beatgrid, these:

  • I’m Really Hot (R-You Bootleg) (Clean)
  • Certified Quality!

Deleting them or re-analyzing them (enable overwrite) should fix this problem.

Next Lexicon update will automatically ignore those invalid beatgrids when syncing.

1 Like

Excellent, thank you. This has resolved the issue, full sync completed in c. 3 min after this fix.


@Christiaan & @Rad_Bee please please please help me (a n00b) out. I’ve had this problems for months now. Formatted my sticks like 50 times, did every thing over and over again and it keeps freezing at some percentage. I’ve searched on the internet for it for hours and hours and this is the first time, that I finally see somebody that solved it! Can you guys please tell me how I make that log or where I find that log, so that I can also check which files are invalid and that are probably causing this proble? Thank you very much!

@88armando Just to be sure, your RB sync is freezing when syncing it to a USB?

Armando I the re-analyse helped when trying again to export.

You can export the log from the menu of Lexicon.

I think the new Lexicon release that skipped invalid beatgrids also solved the problem.

Yes that’s right. I did the update and now the problem is solved, after months. So that’s great! Thank you very much for you reply!