BPM and Grid Jumps to 120 After Syncing from Lexicon to Engine

Please fill in this bug report template:

Lexicon version: …
Operating system: Mac (remove one) 0.3.31

Bug description

Describe the problem. Please add a step-by-step to reproduce the problem. Here is my workflow. Hopefully, I am doing this properly.

I manage my music in Serato.
I import my Serato collection into Lexicon and everything works great.
I export from Lexicon to a brand new Engine database with grids unlocked.
Everything works perfectly in Engine desktop.
I then use Engine to export my playlists to an SD card for the SC6000M.
Everything works perfectly.

Here is the problem:
After adding new tracks to Serato, I import new additions into Lexicon.
Everything works perfectly.
I then export from Lexicon to Engine and this is when the problem occurs.
Everything seems to export into Engine properly, until a track is loaded onto the virtual deck. Then, the tempo and beat grid is changed to 120 BPM. This seems to happen on my older tracks, not the newer additions.

If I delete the Engine database folders starting with a fresh Engine database, then export to Engine from Lexicon - then everything imports into Engine fine again. I feel that locking the grids when exporting from Lexicon makes the problem just as prevalent, if not worse.

The issue seems to occur when updating Engine from Lexicon after my first - initial sync.

Thank you.


Please add a screenshot for context. If this is about a DJ app, please also add screenshots of the problem in that DJ app.

Evening DJDuctape

Welcome to the Lexicon Forum

Have you tried to export the same tracks directly to the SD Card without using the Engine Desktop? you can do this by changing the destination drive in lexicon during the sync process.

The engine desktop app re-analyzes tracks when they are dropped into the player, this could be the case, with export direct to the SD it will rule out engine desktop as the problem, or will point to something else

I would also select to lock the beatgrid on export too

Let us know how you get on


Thank you Stu!

I have not tried to export directly to the SD Card from Lexicon and I will give it a shot! Is that how Lexicon is supposed to work? Will the players need to analyze the files on the fly when loading them?

Thank you!


It is just another option, I use this route as I find it a big time saver, Engine isn’t the greatest software in my opinion.

If you have the beatgrid locked the player will just generate the waveform on load, but it is pretty quick.

I used to have BPM change issues using Engine previously but exporting from Lexicon that hasn’t happend for me

Technically, if I lock them and export to Engine, will Engine be able to change them to 120 BPM? Would that solve my issue? Much appreciated! Have a great day!

I suspect so but I have not tried in that way, worth a shot

Thank you. Trying it right now. I will report back.

Yep — Definitely a bug. Even with the grids locked, any time it is exported to Engine after an initial export, tracks grids get altered to 120 BPM. Hope this gets fixed. Thanks for the current workaround.

Are you seeing this problem in Engine the desktop software, or on a hardware device?
Can you upload a track where you have this problem with?

Hi Christian,

I am seeing this problem in Engine desktop and it then transfers to the player’s OS when exporting to SD/Thumbdive via Engine desktop. Stu’s workaround does work, but it’s nice having the waveform already embedded into the track. I deleted my Engine database and am doing a fresh export from Lexicon to Engine. Engine is currently analyzing all my files. Everything will work properly when the analysis is complete. That’s the strange part.

When it is complete, I will export from Lexicon to Engine again. The problem will occur and I can then upload a few tracks if that helps out. Would you like me to export with the grids locked? The grid status does not seem to make a difference from my testing.

Thank you, Christian!!!

Grids locked will be better yes, then Engine won’t re-analyze the tracks.

With a weird track like this, hopefully I can recreate it and investigate further.

Will do. I’ll report back tomorrow. Thank you!

1 Like

To add to this, I see the 120 BPM thing happen to one of my tracks. In addition, “lock beat grid” just doesn’t seem to work any more. When I export new tracks to Engine DJ it always analyzes them and overwrites the beat grid, even if I’ve exported with “lock” turned on.

In addition some cue points just aren’t making it, randomly. See the screenshots here:

Unlike the OP I’m importing my playlist from Rekordbox. This was all working in previous versions of Lexicon, so I feel like something has definitely gone sideways with 0.33.3’s Engine integration.

1 Like

Thanks. I did change the database engine somewhat, so all SQL connections now use the same code so that will be the first place I’ll be looking.

@djductape can you upload one of those tracks that has the 120 BPM problem?

Also, to my knowledge - Engine’s initial analysis just reads the information. Re-analyze will actually write to the track. This sounds correct as my first import from Lexicon to Engine on a blank Engine database works flawlessly. I don’t know how to explain what might occur on the exports after the initial that might cause this.

@braninling, Can you upload a track with the issue? I am still receiving export errors in Lexicon.

Hey Christian, I can upload a track that the problem happens to, but the track currently works fine, since I haven’t been able to update Engine via Lexicon with the new export error I am receiving.

Here are two tracks that become problematic after the second Lexicon update. They are too large for upload so here is a G drive link: Lexicon Issues – Google Drive

Thank you!

1 Like

I can upload my track that’s failing later, about to head out for the a bit.

The analysis issue for me pops up every time I export new tracks to Engine, even if I set “lock beat grid” to true when doing the export from Lexicon. Engine 2.1.0 in that case does a full analysis and overwrites the beat grid. This is using both an old and completely fresh engine database.

Interesting. For me, when adding new tracks from lexicon to Engine, the new tracks grid is fine and the older tracks grid changes.

I’ll be doing some thorough testing of this on Monday and let you guys know what I find.
@Brainling Would help if I can test your track too. Thanks!