Engine DJ 3.0 update failing

Following the new release of Engine DJ 3.0 today there is quite a bit of noise in their forum around the update failing, as it has for me.

The common thread seems to be lexicon users and the fact that the release notes mention a DB change seems to support this.

Is this something being looked at?

Yep, will release an update to make Lexicon compatible as soon as I can. Expect it in a week or two at the most.

1 Like

Thanks Christian

Hi Christian, I installed beta but failed to sync my base

Can you upload your Lexicon database and Engine database?
Lexicon database from the Help menu.

And Engine database is this folder Music/Engine Library/Database2. You can upload directly to me with this link: http://upload.lexicondj.com

Had another user with the same error, should be resolved in the new beta. Let me know if it all works please

Hi Christaan. I am also having issues. I have updated to the latest version of Lexicon and Engine DJ is showing my playlists as empty with the odd track here and there. All my tracks now are in 1 folder under folders>engine library>music (as pictured)
I have uploaded my Lexicon database and Engine database to you already with a link to this post.

![WhatsApp Image 2023-03-12 at 02.06.23|


Are the tracks copied to your Engine drive?

Since you’re using “folder” in the left menu there, you should be able to see if the tracks on actually on the drive in those folders. You can check by connecting it to your computer.

Yeah they are physically on the SD card in the Engine Library.

I didnt choose to put them in"folder" that happened after I updated to Engine 3.0 and before you made the Lexicon update.

I updated to Engine 3.0 and thats when that happened, saw the posts in here and you explaining that you were working on an update to fix the issues. So I waited, figuring that your update would resolve it. But no luck here yet. :slight_smile:

Does your Denon device give any error or message when starting up? Indicating that your database is broken or something?

It did after the 3.0 update. These 2 screens are the only 2 errors I got on March 3rd.
Then I came here and saw that you were working on a fix so I didn’t use it until I updated Lexicon yesterday.

But since then I have had no errors or warnings.

I think it’s best to delete the Engine database on the Denon device and let Lexicon remake it

So I delete the database from the SD card then re-sync it with Lexicon , Full import or playlist import?

Import is not the same as sync. If you already synced to the SD then that is enough

Sorry, you’ve lost me there.
Can you give step by step instructions what i should do please ?

On the Sync page, select Engine DJ and confirm. That’s all you need to do.

If you are using Denon hardware or a USB, then choose that in the Target Drive option and sync

Hi Christiaan,
So I tried what you suggested and it still didn’t work.
I have started afresh.
I deleted all data bases and reinstalled Engine Dj and Lexicon
I consolidated all my music files onto one hard drive before importing into Engine DJ as it was spread around a bit last time on different drives and folders. Each folder I import is a playlist in Engine Dj
Import went fine, lengthy but fine.
I then tried to import my playlists from Engine DJ on my computer to Lexicon choosing full import rather than playlists as it was a fresh install.
All the music shows up under “Tracks” but their are no playlists in the left hand column. So I deleted the content from Tracks.
I then tried to import playlists from Engine Dj on my computer and it says No Playlists Found (see screenshot)

I closed Lexicon and opened Engine Dj and exported all playlists to a freshly formatted 1Tb SSD and then to a freshly formatted 512Gb SD card. I always carry both as a back up.
I closed Engine Dj and tested both the SD and SSD in my Prime Go and they work fine, all playlists present, all tracks present. No missing tracks.
I loaded Lexicon and then tried to import from either the SD card or SSD drive using the import playlist option.
This time Lexicon found playlists, I selected all and imported. (as screenshot)

After import, there are no tracks or playlists in Lexicon and a report listing all the playlists were imported but no tracks were added. (as screenshot)

Screenshot 2023-03-22 at 22.29.13

I’m now at my whits end and really don’t know what to do next.
One thing I did notice recently is that for some reason some of my external hard drives and the SD card are showing a date modified date as 1 Jan 1980 at 00:00.

This has only happened recently, Lexicon is the only new piece of software I have installed in the last few months. Would you know what the cause of this is, could it be Lexicon? How do I get the date back to normal? Even after fresh formats the dates are still wrong. The files within these drives have the correct dates. All my google searches are pointing back to Mac errors from years and years ago.
I’m stumped. :frowning:

I don’t know anything about those dates, Lexicon doesn’t change those.

I’m working on an update for Lexicon now that has a few minor Engine fixes since the 3.0 release where I had to make some changes regarding importing. That might be related to what you are seeing.

Can you send me your Engine database? From the PRIME SD drive that you tried to import but imported no tracks. It’s the Engine Library/Database2/m.db file.

Upload link

1 Like

I have uploaded 2 files one from the SD card Engine DJ database and the other from my computers hard drive Engine DJ Database.

Just tested your SD database. A full import did work for me but a playlist import with all playlists selected had the same result as you, all playlists were empty.

After looking more into it, it’s because the tracks refer to another database so Lexicon. There will be a Lexicon update today or tomorrow and I’ll try to make Lexicon accept those tracks too.

Meanwhile you can try a full import.

1 Like