Engine DJ failing to export, reporting library corruption, v. 3.4.0, 4.0. Lexicon 1.6.16

My workflow has worked fine for the last couple of years. Big music folder to which I add 5 to 10 songs each week. Open in Traktor, set cuepoints, playlists, tags. Open in Lexicon, import 3 curated playlists from Traktor (about 80gb). Send from Lexicon into Engine DJ as a new Library (no merging). Then open Engine DJ, let it analyze, and then export to USB / SD. No problem with this except maybe some duplicates here and there once in a while. In which case I just delete all songs from Engine DJ Library and then export from Lexicon again for a fresh library in Engine DJ. So after updating to 4.0 I started getting “Library is Corrupt” messages when trying to export to USB. This has resulted in USBs with all my music in them but no playlists recognized. Tried multiple times and with different drives. Same result. Tried downgrading back to Engine DJ 3.4.0 and the same error occurs. Deleted all Engine DJ files and folders from a test computer, installed 3.4.0 which used to work. Imported fresh from Traktor into Lexicon and sent over to Engine. Problem persists. The only new variable is Lexicon updated to latest version. The files and playlists appear fine on Engine DJ on my Mac. I have ran Library Optimization nevertheless.

So now I think that either something is going wrong with Lexicon’s latest version, or there is something truly wrong with my Engine software and having switched to the new database format in 4.0, even though I have deleted that and reinstalled 3.4.0 (which used to work fine) on my test computer. I am getting these errors on both computers and both versions of Engine (3.4.0 and 4.0).

Sorry for this long post that might end up not being related to a problem with Lexicon, but while it remains as one of the variables involved, posting here might help.

Is there anyway to roll back to a previous version of Lexicon just for testing purposes?


MAc OS Sonoma 14.5, MacBook Pro M1 Pro & M1 Max.

It’s not possible to roll back unless I create a specific version. But can you send me your corrupt database? I’ll give it a test here and see what it shows.

You can upload with this link: http://upload.lexicondj.com

Engine has updates to their database once in a while so could be they changed something that I’m not aware of.

Not sure if you use the Add album art option but you could try without that option.

I dont think its a Lexicon problem per se except many people are using Lexicon and not stating this but free to have a look at the DB here

Another DB is here as well

Sure, thanks a lot! Shall I send the whole Database2 folder? There is a Lexicon folder inside it with a couple of backups that are around 500mb each.

@DJDL apologies for hijacking your thread. I reported the same thing a week ago as well.

The more the merrier! Sorry you are having a problem as well. Hopefully It’ll get sorted out soon.
Perhaps your DB uploads are enough for dev to find any possible issues. If you still need mine, I’ll upload it as soon as you tell me if the whole thing including those big backup files are needed.

I don’t need the backups

The upload is complete, thanks!

@DJDL can you try this database? engine database optimized.zip - Google Drive
It’s the same as you sent me but I optimized it, it might help.

I relocated 2 tracks in a random playlist of yours and exported it to a USB without error.

Hi Christiaan, thanks for helping out. Sadly, the problem persists. Dragged your updated DB file into my EngineDJ 4.0 Database2 folder and tried exporting. The enclosed message appeared after about 5-10 minutes into de export process. So after this warning, the process continued, and the music was copied to the external drive (I can browse the music folders from the finder), but browsing the drive’s collection in Eengine shows neither playlists nor tracks.

I also opened a ticket with Denon Support but haven’t heard from them.

This is an engine dj problem

Are you on the engine forum?

brand new mac mini, no lexicon. I installed EDJ 4.0 for the first time and boom corruption

I built a library from scratch and tried exporting it

I have tested on 2 macs and a PC - same outcome


They have tried to finger Lexicon as a potential culprit

Could it be that some music files are the problem? Maybe it tries copying but fails?

Since i only tried a random playlist of your library @DJDL , perhaps the problem lies in a specific playlist and/or track that I didn’t use. So narrowing this down to a small playlist or even one track would be super helpful

This crossed my mind

So i did a broken track process both in Lexixcon and Serato DJ

I removed like 5 broken tracks found completely from my library. These tracks have existed in my library since Serato Scratch Live btw and have worked fine with all previous iterations of EDJ and Serato.

I built another database from scratch without these tracks and yet the export corrupts.

I even went further by building a database directly from my folders (ie no serato, no lexicon, no hotcues, no analysis) - guess what …corrupted on export

I chose only one of my 3 main large playlist folders for export and this time it worked fine. I am now trying to add the second folder for export and see if it works too. Like you suggested, the hope is narrowing down any file or folder that is having issues, and see what the culprit is.

1 Like

Well, strange. I was able to export the first playlist just fine, then added the second one and no problem either. So I figured that the third one might be the problem, so I exported it by itself and it went fine as well. So no bad tracks in either of them. Music was exported, and playlists were all there.

I then went ahead and exported all 3 playlists together and this time the corrupted library message popped up towards the end of the export. I am exporting around 90gb to a 256gb drive that I have reformatted from scratch each time as Exfat, just to start clean. The drive is brand new. Tried another drive and had the same issue. Go figure!

There is another issue. If I export the Engine Library from Lexicon into EngineDJ from scratch, I end up exactly with what I wanted, a copy of my Lexicon Library that replaces whatever Library or Collection was there before. But if I go to EngineDJ and try to delete a song from the Engine Library/Collection (Delete from Collection), it will present a warning saying the song will also be deleted from my hard drive. I tried this on a test system and actually lost 75GB of music files that got wiped out from my main music folder just by removing them from my Engine Library. I post this here because I believe it was not like this before; it just started happening to me in my 2 computers at the same time as this other issue with library corruption.

@mufasa So definitely seems like the tracks cause this? Can you send me those? http://upload.lexicondj.com
I suspect Engine is loading missing file info like bitrate, duration, etc and tripping up on those files.

@DJDL I’ve seen that before myself twice, Engine deleting files from disk even though it normally shouldn’t do that. No idea what causes it and was not able to reproduce that.

Sadly, it is like this for me now. Cannot remove files without causing chaos in my music files. Luckily, I seldom need to do this, as I tend to replace the Denon Library completely via Lexicon on a weekly basis.

I wrote this in the ENGINEDJ forum: “Now I am trying another approach, which is foregoing the Sync Manager altogether, and dragging individual playlists within the DRIVES column. From my main drive, into my USB’s collection. I have successfully exported all of my playlists to my SD card this way. After many days trying to work things out, this method is now a viable workaround. The problem is still there, but copying manually instead of using the Sync Manager stands as a temporary solution.”

If you scan for broken tracks and remove them, It solves issue.


1 Like