Engine DJ not finding Serato Crates After Lexicon


Brand new to Lexicon. I use Denon equipment with Engine DJ on a PC. I also use Mixed in Key for cue points, which doesn’t work directly with Engine. Old work flow workaround was to run MIK, then load in Searato first, then synch Engine DJ to Serato within Engine DJ.

Now that I have Lexicon, I imported my Engine DJ library in full to Lexicon, then exported the whole Lexicon library to Serato using Lexicon. But now, after adding new tracks from MIK to Serato, when I go to synch Engine to Serato within the Engine DJ app, it doesn’t see any of the Searato crates anymore. They just don’t appear within Engine DJ/Searato synch anymore. Did Lexicon do something to the Searato crates such that Engine DJ doesn’t recognize them anymore? It’s like they are invisible to Engine DJ now.

I realize I don’t necessarily need to do this anymore as lexicon can take over from Engine DJ’s built in Serato library integration. But I don’t want to be dependent on this functionality where it worked fine before without the need for Lexicon.


I don’t know exactly what Engine does when importing or exporting to Serato so I can’t give you anything useful there.
But the recommended workflow is to manage your tracks and playlists in Lexicon and only sync to your DJ apps.

Got it thanks. Will figure out a new workflow. If Mixed in Key cue points worked directly in Engine would make life simpler… Still waiting for that to happen.

OK, I realize sort of drifting topic but all related to MIK-Lexicon-Denon workflow.

I tried taking Searato out the flow entirely per your suggestion but ran into issues.

Get track from Beatport
Analyze with Platinum Notes, which creates new pn file
Analyse that new pn file in MIK (with auto cue points)

All good so far

Drag and drop the pn file into a new Lexicon playlist
No tags, no cues, no key. Nothing from MIK made it into Lexicon

Checked MIK settings to make sure matched this guide:

They did.

What am I doing wrong?

OK, subsequently tried opening the same tracks in Serato. Saw everyting MIK added just fine. THEN I added the tracks to Lexicon again, and everything looked good now.

It’s like I had to open the tracks in Searato first for Lexicon to then recognize the info MIK added.

Is there a way to eliminate this step?


Sorry, I take that back. After opening in Searato first, Lexicon saw the key and artist name and a few other tags for the first time, but still no cue points. Weird.

Lexicon auto reads MIK cues points when you drag a trak in Lexicon and the track is new. If it already exists, it won’t reload those cues when dragging in.

Alternatively, you can right click tracks and Reload Tags, that will also load MIK cues if no cues were on the track yet

Strange. I’ll try again with a new track and report back, but did not work yesterday.

1 Like

Make sure you are on the latest Lexicon. The Reload Tags for MIK cues was only added in 1.5.2

OK tried this again and simply not working. I run Patinum notes, which creates a new file. I run MIK on that file. Cue points set. I drag that file into Lexicon, but nothing from MIK is showing in Lexicon. No cue points, not neven the key. Tried exporting cue points again, no luckl. Updated everything too. Want me to send youn the file?

I saw the same problem with another user, he had to right click tracks in MIK → Export Cue Points

After that, it works as expected in Lexicon

Ok I believe I’ve isolated the problem (and an inefficient workaround, but not one I’d want to use permanently!). It’s something about Lexicon and Platinum Notes.

If I run platinum notes on the track, either before or after MIK, Lexicon cannot see any of the MIK tags or cue points.

If I don’t run Platinum Notes, Lexicon can see them.

And if I run Platinum Notes, then open the track in Serato, I see all the MIK data. And if I then import the relevant Serato playlist with the track from Serato into Lexicon, Lexicon can now see the MIK data. But Lexicon cannot unless I go through this intervening step.

If you use PN, you should use it as the first step, before doing anything with cue points. Because PN changes the audio and cues will get moved slightly to an incorrect position

I do use it as a first step, before running MIK. I only experimented once with using after MIK to see if that changed the outcome. No matter when I run it, if I run it I get the problems I’ve outlined. Very confused why PN seems to be throwing Lexicon for a loop unless I open the file in Serato and import to Lexicon via a Serato playlist. Thanks.

Checking back here if any thoughts. Thanks!

I suspect PN clears the ID3 tags that MIK creates. Lexicon reads those custom ID3 tags, they contain the cue points from MIK.

I have the issue if I run pn before MIK though.

Can you send me a track that you’ve put through PN and MIK in that order?

Upload link: http://upload.lexicondj.com

Yup will do.