Failed to sync to Engine DJ

I am unable to sync with either Engin DJ Desktop or USB. I have deleted the database on both the Desktop and USB, and have formatted the USB. But I still receive an error message every time.

In advance, I used “find duplicates” and went through all of them, which were extremely numerous. It took a whole day to get through.
So this should be resolved without me having to restore a backup.

It’s quite odd this would happen with an empty USB, since Lexicon creates the database.

Can you upload your Lexicon database & logs? From the Help menu.

Uploaded now.

That’s what I find very strange too, so I’m going crazy.

PS! Sync to Rekordboks went without error message.

How many tracks are you syncing? Maybe the disk is running out of space?

And are you using any other program (like Engine) during the sync? Cause that would definitely break things

Could also be a virus scanner interfering… Try a reboot, it can sometimes help

No, I have twice as much free space on both the hard drive and the USB stick.

No, no other programs related to music are running at the same time.

I am using Mac, and there is no virus scanning here.

Have you tried a reboot?

I deleted the database for Engine DJ (Database2) and performed a restart.

Then I started Lexicon DJ and initiated a sync. It gets stuck at 78%, and the same thing happened the other day. It stayed at 78% all night, and Lexicon didn’t freeze, it just kept running as usual.

Can you upload logs again?

I have sent it again.

This time it went from 78% to Failed to sync to Engine DJ.

Can you disable the album art sync option and try again? Might be related to that

1 Like

Yes, it looks like it solved the problem.
Now the sync went until it finished, and all the songs are in Engine DJ.
Now it just needs to analyze all the songs again since I had cleared the database.

Thank you very much for your help, and for sticking with it until we found the solution.

Thanks for not giving up, I have an idea how to fix this now in a Lexicon update :+1:

1 Like

What I like about Lexicon is the speed with which bugs are fixed and the direct contact with the software developers. :muscle: :muscle: :muscle:



Today’s update has a potential fix for the problem, so you can try to enable album art again.

I am seeing this behaviour even on the latest version, it also effects exporting from EngineDJ to a usb, only effected when either Album Art on in Lexicon and exporting direct to USB, or after re-importing track info on EngineDJ, it does seem to be related to the artwork, I have reloaded the artwork using the find tool onset with Spotify only.

Hey Stu :slight_smile: Welcome back

Can you upload your logs? I’ll take a look

Hi Christiaan

Thanks for the warm welcome, sorry I have been so absent for so long, things are better now so hopefully I can contribute a bit more again

I am running another export without artwork right now, I will upload when that has finished

Hope you are well and not too busy?


I have uploaded my logs

Nice to have you back :slight_smile: All is well here, everything is steady in the Lexicon world. And I’m the proud dad of a little girl now :smiley:

And the bug; it’s a weird one, looks like the database has a problem. Doesn’t seem to always happen with the same thing, different each time which is unusual. Can you upload your Engine m.db file?

1 Like

Oh wow congratulations, so happy for you

I have uploaded the m.db file

1 Like