How to manage "Set Active Loop" for Rekordbox memory loops?

Something that I do often in Rekordbox is set a memory cue near the end of a track with a loop that activates automatically when the play head hits that cue. Screenshot for where this is toggled on/off:

From what I can tell, because Lexicon converts all cues to hot cues, this “Set Active Loop” setting is not retained. I would assume that when I re-sync Lexicon back to Rekordbox that I’ll loose these automatic loops, and that I will no longer be able to create them if I’m managing my library primarily from Lexicon. Is this true? And if so are there plans to support this in the future somehow? I see some mention of active loops in the changelog but that appears to only retain the setting on imported tracks, but not edit or create new ones.

Active loops should be maintained when imported and synced back. But yes you cannot set them in Lexicon yet

Makes sense thank you @Christiaan! I’ll post in feature requests so you can track interest :slight_smile:

@Christiaan I’ve been setting active loops in Rekordbox, syncing to Lexicon, not changing anything on those tracks or their cues, and syncing back to Rekordbox, and the active loop toggle has been disabled. This has unfortunately disabled every memory cue with active loop set for my entire library. The memory cue loops are still there but no longer have active loop toggled.

Seems like this might be a bug?

This is with the default import and export cue settings as well. I tried only importing hot cues from Rekordbox and only exporting to hot cues, and it deleted a bunch of the memory cues in Rekordbox but weirdly not all of them…!

Can you try the Lexicon beta version? I think active memory loops were not supported yet but they are in the beta version. You can switch in the settings, at the bottom

That seems to have fixed the issue thank you!

1 Like