Importing library never works as it should

If I import from Serato DJ database there are tracks missing in crates (1 crate/playlist has 200 missing tracks) as well as cue points loading up in the wrong places.

If I import from Engine DJ the same thing happens with missing tracks but the cue points are in the correct place. I am at a loss as to why this is happening.

Does anybody have any ideas?


Are you on the latest version? For Serato there was a bug that gave empty playlists

And check if you have the Only new tracks & playlists option off. When it’s on, it won’t update existing playlists so if it was empty before the import, it will stay empty.

Hi mate. Yes I am running latest version of Lexicon and Serato DJ. Also the only new tracks option is off.

One of my crates was missing all the files.

Also I noticed when I exported to EngineDJ even when that had analysed and exported I couldn’t edit the beat grid on the hardware but if I import from Serato direct to EngineDJ I have none of these issues.

I’m running MacOS in case this makes any difference.

One thing to check that is a known issue for Mac: maybe there is a colon : or slash / in the location of any of those tracks? Those are problematic (soon to be fixed) right now.

Otherwise, can you upload your Lexicon logs? From the Help menu and I’ll take a look. Put this forum link in the description please.

I’ve figured out the majority of issues are caused as most of my files are MP4 music videos.

Can you upload your logs? Maybe there is something I can see in there that needs fixing for MP4 files

any update to this?

Ya I’m having the same issue trying to transfer from traktor to rekordbox. It worked once but now I’m getting errors saying it can’t find files even though I manually locate them

@MattyE Sorry about the delay. I’m releasing a beta version today that should address this problem. Can you give that a try and let me know if it solves the problem? I’ll share the link here, it’s also in Discord

@BreezyDoesIt Can you make a new topic about the problem you’re having? With screenshots please so it’s easier to understand the exact problem

@MattyE The beta release (beta-6) is online, you can switch to it in your Lexicon settings → App Settings → Release Branch. Put it on beta and you’ll get it

ok brilliant thank you. I will try in the next few hours. just finishing up some work.

just tried with the beta. Looks like the issues are solved!! Thank you so much. The gearshift worked fine on the mp4 files and crates seem to have all the tracks in. I can now work on getting everything converted to MP3 and duplicates etc gone!!!

Great! :slight_smile: Let me know if something pops up!

the beta today seems to be struggling so much with finding album artwork. I know I have to stay to 200 files or less currently but even that is an issue.

Can you make a playlist in your Lexicon with tracks that are not finding album art, but you are sure that Lexicon should find them. So no bootlegs, unknown remixes, etc. And clean titles and artists of course.
Then upload that database from the Help menu and mention the playlist name. I can take a look easily then.

Sorry I don’t think I explained it right, it is finding album art but it is crashing and freezing when trying to pull results and I have to restart the app and it’ll then work for a while.

Can you keep an eye on the task manager when it is finding album art? Check if memory usage keeps going higher. Or make a video of the task manager for a few minutes until it crashes, so I can see it

I am seeing the same behaviour on album art find, I will run a block again at the weekend and try and grab cpu usage for you

1 Like

I’m especially interested in how memory usage grows over time. If it only grows and never goes down, that is a memory leak and would explain a random crash

1 Like

Ok so just ran a batch of 1348 tracks, got stuck at 14%, no linear increase in memory usage, hovering around the 200MB-250mb area, up and down the whole time