Special characters in engine os

Please fill in this bug report template:

Lexicon version: 1.5.9
Operating system (remove one): Mac

Bug description: Tracks with special characters are not playable on sc6000 after Lexicon export, not a Problem when working directly from engine DJ

Step by step to reproduce: When exporting from Lexicon to Engine DJ (then syncing to sc6000 with Engine OS) there is a problem where tracks with special characters are displayed in red on the sc6000 and cannot be played. If you add these tracks directly via Engine DJ there is no problem. In engine prime on my Mac these tracks are always playable. I suspect that this is related to the ID3 conversion of Lexicon.

Screenshot:

What special characters do you mean exactly?

e.g. é, ç, í

Thanks, I’ll look into that

Nice. Looking forward, as this is driving me crazy right now. There are some complains in the engine forum with those red marked tracks related to id3 tags and UTF writing. So thats my best guess. My files are mainly aiff and have ID3v2.3 + UTF-16

Thanks, that’s useful info. I will do some bug hunting on that this week

Can you upload your Lexicon database & logs? From the Help menu.

And do you have a few examples of tracks that are showing as red in Engine?

Just uploaded the logs.

examples:
David Löhlein - Facelift (Album MTY-AIR - “Mille attaques, les vents contrèrent”)
Reeko - Energía Magenta
François X - Cowboy Executive Officer

and so on. All of them have the special characters in common. Interestingly i can’t find them within Lexicon if i don’t type the special Character right. E.g. can’t find Energia, have to type Energía

what i have found to be causing the red files on the OS side of things appears to be the folder based on artist name that engine creates on the performance drive.

it seems to affect libraries that are imported from Serato databases in my case.

I believe if the library was created in engine dj from file/finder and exported to performance drive the reds dont occur.

if we take this track for example, on the export drive, a folder will be created titled “David Löhlein” and therein lies the issue.

i will test my hypothesis now and revert.

I tested with two tiesto tracks

Tiësto in artist field and in title field

The tracks worked fine, irrespective of how i imported them to main library and exported to SDcard.

I also tested with Tiësto in the filename. Worked fine as well.

I’m using Engine DJ 3.3.0.

Yeah that was my result as well, all tracks worked with any combination of accents. I’ll try again with the data from the Lexicon database from @AlDo

No problem with your database either…

@AlDo Can you try deleting the Engine Library folder from the SC6000, then let Lexicon sync again? It will copy everything to it again.

Could be that it is just an incompatibility between how Engine and Lexicon copy tracks

Deleted the engine library on the sc6000, formatted the drive, made a fresh sync. problem still occurs…
Seeing additional problematic tracks of Chlär, YÅ and tracks like “Revolté” (maxime Dangles) and “nyama mabé” (Fabian Wegmeth). Interestingly i have one remix of François X in mp3, where the Problem does not occur. Rest is in aiff.




Tracks added manually added in engine Prime: no Error after sync. But “red version” of tracks synced via Lexicon still persist.



Not sure then… You have it formatted as exFAT I think?
Might be an SC6000 issue? I have a Prime 2 to test this on

I hope you all had wonderful holidays!

I found some time to look into the problem again… - I noticed something obvious: The “ö” in David Löhlein is formatted very strangely after export from Lexicon. As if it only had one dot instead of two. This happens regardless of whether the track was exported to aiff, mp3 or previously edited with mp3tag. All versions are displayed in red in engine os. You can also see the strange “ö” here. Something is not right… - I would be so happy if we could solve the problem!


What I really don’t get: When working directly over engine prime, no problems. Syncing from lexicon to engine prime: red tracks.

What would help me fix this is if you can make an export of the same tracks and upload the Engine database twice. Once after syncing from Lexicon and once after syncing from Engine.

The Engine Library/Database2 folder is what I need and you can upload with this link: http://upload.lexicondj.com

Thanks for getting in again! So I sync from Lexicon to engine and upload the Database 2 folder.
What do you mean by “after syncing from engine”?

I mean when you use Engine to send your tracks to Prime. Do that for the same tracks (so they work on the Prime), then upload the Database2 folder again.

So I should get 2x the Database2 folder, once where your tracks on the Prime are red and once where your tracks do work. Then I can compare the two.