[Sync] LXC not syncing beat grids to Serato

Please fill in this bug report template:

Lexicon version: …
Operating system (remove one): Mac

Bug description:
(1) LXC is deleting Serato beat grids.
(2) LXC also removed track color.

Step by step to reproduce:
(1) Generate beat grids in Serato.
(2) Import the tracks and playlists containing beat grids into LXC.
(3) Sync the playlists back into Serato.
(4) Verify beat grids in Serato…

BPM and cue points were synced, and the beat grid was deleted. Also, notice that the track color was removed as there isn’t an option to import track colors into LXC. I opened a separate ticket (link below) for the track colors but mentioned it here for context.

[Sync] Option to import colors is missing (or not included)


By the way, I believe Color, Key, BPM, Beatgrid, and Cue Points should be grouped in the far right column; those five tags tie more together for DJ apps.

What kind of tracks are these? MP3 or something else?

The track in the screenshot is MP3.

Can you upload that track? You can upload directly to me with this link: http://upload.lexicondj.com

Mention this forum post link in the description please.

I’ll take a look tomorrow and get back to you


I sent it over twice; with and without the grid from Serato.

I looked at it with Kid3 and this track has double Serato tags which I think is confusing Serato. I think Lexicon overwrites one of the two tags but maybe Serato only looks at the other one so nothing shows up. So this is a corrupt file really (tags must be unique) but I’m not sure if Serato or Lexicon made it like that.

I’ll have to look into letting Lexicon auto fix double tags if that is possible, I’ll see if I can put that in the next update.

1 Like

Hmm, that is interesting. Is there any way I could erase the Serato tags?

I tried Kid3. I saw what you mentioned, and I was able to recover the beat grid.

I am hopeful you will find and implement a solution for this in LXC. :slight_smile:

1 Like

Have you tried syncing that track a second time to Serato? Because it should already auto fix the problem.

This is what I did:

  1. The track had no beatgrid in Serato.
  2. I gave the track a new beatgrid in Lexicon
  3. Sync to Serato
  4. Open with kid3, no more duplicate Serato Beatgrid entry
  5. Test in Serato, beatgrid is there

Yes, I have tried this.

I also see that tracks I correct in Serato are reverted after exporting.

It’s difficult to say how far this issue goes. I notice the issue predominately in my live sets. I pull up a track I have played before LXN only to realize that the beat grid or cue points have been erased.

I began wondering if the tracks were being affected based on whether or not I had a controller plugged in.

I just checked on five songs I had issues with on Saturday, August 27.

(1) I made sure they were correct in Serato.
(2) I imported the playlist that contains these tracks into LXN and verified that the beat grid and cue points matched Serato’s.
(3) I synced the playlist back into Serato.

The tracks were all affected again; beat grid and cue points were erased in Serato.

I can send you before step by step images and files if necessary.

I have attached my import settings below.

Can you try resetting Lexicon from the Help menu? Maybe there is a problem with the underlying program that modifies the ID3 tags

And you’re on the latest Lexicon version, right?

I tried your suggestion; the issue remains. When you said “resetting” you mean Help > Cleanup, correct?

Yes, I am running the latest version (1.1.26).

Okay, strange that my version does auto fix it.

Can you check with kid3 if you already have one, two or zero Serato Beatgrid tags on the files before syncing with Lexicon? I’m wondering where the second one comes from.

I have 2-3 that reads Serato BeatGrid on the files before syncing with LXN; I have 1 after the sync.

I do see another that reads BeatGrid; this tag remains after the sync.

I think that’s not Serato related, might be from Mixed in Key.

So after using Lexicon, there is one Serato BeatGrid tag, which means it should work in Serato then. Or do those still not work, even with one tag? And no other duplicate (invalid) tags?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.