Sync to Engine fails with SQLite error

Syncing to Engine DJ fails with a ‘Sqlite rror : no such table : information’ error

Have tried full sync as well as selecting all the playlists. Have also tried restoring from a recent backup.

Engine options selected are full beatgrid lock and sync artwork


This might be an old Engine database. Are you on the latest Engine DJ?

yes, 2.4

Are you syncing to a Denon device directly?
You can delete the Engine database on there and let Lexicon re-create it. Even better to just rename it so you can always put it back.

i was just syncing to the database on the desktop.

I tried doing a full sync to USB and it worked. I thought I’d then be able to do a sync back to Engine desktop, but when I do that the ‘sync to engine DJ’ button is greyed out indicating there is nothing to sync back which doesnt make sense as I know my full library isnt on the USB drive.

I’ve also looked at the DB with a DB tool and can see that there is a table called information in the m.db database file, if that helps

The db might be corrupted. If you have everything in Lexicon now, you can try deleting (or rename) the Engine db at Music/Engine Library/Database2 (just rename that folder) and then start Engine once to get an empty db. Then full sync again.

just tried that and get the same error Im afraid

this is the error in the logs:

[2022-12-31T15:39:57.184Z] [error]: SqliteError: no such table: Information
SqliteError: no such table: Information
    at Database.prepare (C:\Users\miles\AppData\Local\Lexicon\app-0.99.33\resources\node_modules\better-sqlite3-multiple-ciphers\lib\methods\wrappers.js:5:21)
    at DatabaseConnection.executeQuery (file:///C:/Users/miles/AppData/Local/Lexicon/app-0.99.33/resources/app.asar/.webpack/renderer/main_window/index.js:2:2281962)
    at DatabaseConnection.selectSync (file:///C:/Users/miles/AppData/Local/Lexicon/app-0.99.33/resources/app.asar/.webpack/renderer/main_window/index.js:2:2283405)
    at EnginedjDatabaseWriter_EnginedjDatabaseWriter.init (file:///C:/Users/miles/AppData/Local/Lexicon/app-0.99.33/resources/app.asar/.webpack/renderer/main_window/index.js:2:2730181)
    at processTicksAndRejections (internal/process/task_queues.js:97:5)
    at async EnginedjExporter_EnginedjExporter.start (file:///C:/Users/miles/AppData/Local/Lexicon/app-0.99.33/resources/app.asar/.webpack/renderer/main_window/index.js:2:2995186)
    at async l.onClick (file:///C:/Users/miles/AppData/Local/Lexicon/app-0.99.33/resources/app.asar/.webpack/renderer/main_window/index.js:2:3075691) {
  code: 'SQLITE_ERROR'

there are a few similar previous errors, but with this immediately after:

[2022-12-31T15:39:56.919Z] [error]: QUERY FAILED: 
FROM Information

Maybe it’s a permission issue that the database can’t be created properly?

I’m not sure that can be the cause as I had the same issue with the DB there initially

Weird because it should always work with an empty Engine database. Can you try updating to the latest Lexicon version (new update released today) and try again?

Yes, saw that and tried it too, same thing. It is weird.

Trying to think what has changed on the denon side and all I can think of is I did a backup and restore of denon previously. The restore appeared to work, but ended up popping up a message about being unable to complete the restore after every restart. I’ve had this before and the ‘fix’ is to rename the engine folder and then also rename another folder called restore to the normal name and engine picks this up and the error goes away. I’m wondering if this has got something to do with it.

Not sure but I can check your Engine database. Can you zip and upload the m.db file from your Denon? You can upload directly to me with this link:

thanks, just uploaded

I’m at a complete loss now. I’ve completely reinstalled EDJ and renamed all engine related folders. I started with a complete clean sheet and an empty library as expected. When I try to sync a single playlist I get the same error.

That would indicate its not a Denon issue?

I’ve tried reverting to the stable release version by changing the option in the settings. I was expecting it to need to restart or somehow reinstall the stable version but it just restarted straight away with no obvious difference. I can see the setting changed to stable release, but is there anything else I need to do to revert to the stable release? Want to make sure that hasnt got anything to do with it

Just tested your database but it works fine here. Full Sync to Engine desktop with your database worked without problems.

I’m pretty sure this is not related to Lexicon or Engine now, but your computer. Maybe some other software, virus scanner perhaps, blocking Lexicon or access to the database file?