Syncing back to engine results into all empty playlists (not groups)

SOLUTION: Sync from/to **(INTERNAL)** Target/Source drive

Please fill in this bug report template:

Lexicon version: 1.1.4
Operating system: Windows

Bug description:
In lexicon (imported perfectly from engine) all is ok (example shows a playlist containing 155 files)

After a sync back to engine… ALL my lists are empty all of a sudden? (same playlist but empty…):confused:

This happened to whole my Engine library btw… :confused:
When clicking the groups the tunes apear, but when going deeper to the lists in the groups… those are empty…


Step by step to reproduce:
Imported from engine to lexicon
Did some edit recipes
synced from lexicon to engine again
open engine and started to shake a bit …

Sidenotes that caught my attention:
Finishing up Realy takes a lot longer than previous version
it seems the problem happens in this structure

Can you upload your LXC database? From the Help menu

I might have already fixed this in the next release, please try again there. Found a similar bug when testing Engine.

1 Like

Upload is on it’s way.

Shoot if you need some more info @Christiaan .

Grtz N.

Any chance you could release it before the evening?

Got a gig coming up tonight ^^ would be a big help.

Release is imminent but I can’t guarantee it fixes your issue. Won’t be another release today though.

And if it does not, try fully deleting your Engine database, that sometimes fixes issues

1 Like

Just did that. Re-Syncing as we type.
Fingers crossed

edit: NOPE made it worse ^^

The Lexiconbase is on point, so i’m good. 've got faith in you @Christiaan. It’ll be a small matter of time & i can easily sync it up again. no doubt :wink:

But on the other hand since the day i’ve paid for it problems came up… any chance i could downgrade some versions?

for now i can just drag the right lists from serato to engine.
it works but takes time


So i connect the drive i use on my prime 4 to my computer so i can drag my newly added small playlists to that drive…

AND POOF!!! all of the sudden everything in Prime is back…

i close Engine, disconnect the drive, restart engine and everything is back…

Hmm okay… Maybe Engine is doing some kind of correction on the database there…

How is the export looking now, with the latest version? I’m kind of lost on the status

Just tested, Still the same problem tho’

And this is with an empty Engine database? And do you have any Engine databases on other disks?
It might be related to one of those.

Can you upload the Engine database from the internal drive? Right after the sync. Don’t open Engine after the sync because it might change the database.

Upload link

I will make 3 folders:

  1. a proper back up of the functional engine database atm.
  2. import that one into lexicon, will put the lxn db in folder 2.
  3. Then i will sync it with lexicon to engine again and put this db (before opening engine into folder


Yes, sounds good! Thanks

1 Like

Files are on their way.

Just started

Something is weird because Engine says “Upgrading library” when it loads and there are too many database files (seems like old Prime files) in the Database2 folder.

Can you try renaming the Music/Engine Library folder, then starting Engine once (should be empty, otherwise make sure to also rename the Engine Library folders on each disk). Then sync from LXC and check the playlists again.

What i’ve just done:
1- i grouped EVERY file in another folder that’s NOT Database 2


2- reopend Engine again… all still ok… so i presume i actually can delete that new folder called “OLD” ??
(tried this first so i know that this db is a safe one that is complete & works…)

After that
1- i renamed the “Engine Library”-folder to “–Engine Library”
2- i reopen Engine and indeed a) it makes a new “Engine Library”-folder. and b) Engine is empty.
3- Close Engine
4- i do a FULL Lexicon to Engine sync… to the newly made engine folder
5- I close Lexicon
6- I Open Engine again
7- RESULT: Engine needs to analyse all tracks to link the db-files with the file-paths again (i presume)
After analyze procedure: UNFORTUNATELY EMPTY LISTS AGAIN… :frowning:

Can you check if you have more Engine Library folders on any other drive? They will always be at the top most folder (root) of the drive.

I tested your Engine Library folder here earlier but I did see tracks and all playlists so I’m wondering if a different Engine Library folder is causing this maybe.

oh wait yeah i just noticed one next to the music folder itself…

which contains


which contains


I do just noticed; when i sync a certain playlist instead of full that works, not all groups show the tracks but the lists inside the groups do…

Any chance i could go a few versions back because at least 4 versions ago it worked fine for me :confused: