Unable to drag tracks into Lexicon or Play tracks

Please fill in this bug report template:

Lexicon version: 1.6.7
Operating system (remove one): Mac

Bug description:

When I drag a track into lexicon, nothing happens. When I tried to play a song I got Error code 126 when trying to play track

Step by step to reproduce:

  • Setup a brand new mac
  • Install Lexicon
  • Try to drag song into lexicon
  • Restore from back up and try to play song


I think you might be using the wrong Lexicon for Mac. Make sure you download the right one here: Download | Lexicon - DJ Library Management

Hi Christian,

That’s exactly where I downloaded from.

Here are a few things I have tried:

  • Restart my mac
  • Reinstall Lexicon

Do you have an Apple Silicon (M1/2) mac?

Yes. M1

I needed Rosetta. Installed Serato which installed Rosetta and it’s fine now. Maybe a documentation on installing Rosetta for M1/2 macs would be helpful

Yeah true, normally it should ask you to install it though. I’ll add this to the docs

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.