Export to USB from Rekorbox shows corrupted data files

Please fill in this bug report template:

Lexicon version: 1.1.7
Operating system: Mac

Bug description:
I am having issues with export to USB from Rekordbox after syncing with Lexicon. I noticed this issue during the beta and just got around to purchasing Lexicon to try again.
I uninstalled Rekordbox, and installed a new copy of it (Version 6.6.2). Then updated to the latest version of Lexicon (1.1.7)
Rekordbox is reporting this in the log file: [4] - Track analysis data is corrupted or doesn’t exist.
I have attached 3 screenshots of rekordbox. 1 is my playlist with 317 tracks. 2 is the playlist on the usb with only 63 tracks and 3 is the Rekordbox log file.

Most of the tracks are not syncing. Some tracks appear in the playlist with analysis data, and some do not have analysis data (missing the preview waveform).

Step by step to reproduce:
Sync Lexicon to Rekordbox
Rekordbox: Pick playlists to sync in Sync manager, then sync
View the USB under devises tab to verify what tracks have been synced
View the log file to see what tracks were not synced


I’m aware of this bug and this is the most weird and obscure bug that there is right now. I suspect this is a bug in Rekordbox since I have the same problem in my RB when LXC is not involved at all. Even after completely deleting the RB database and starting over without any LXC involvement, I still get this problem. So at the moment I don’t have a fix for this since I don’t have any more information than this error message that doesn’t really tell us much.

Still trying to find it but I’m not sure where to look anymore, I’ve spent many hours on it already.

Any news on this? I still can’t access 60% of my library… I can’t understand how this bug exist. :frowning:

1 Like

Just did a test by downloading new songs and opening Lexicon. None of the songs I analyzed in Lexicon (re-analyzed in Rekordbox) had their beatgrids transferred when exporting from Rekordbox. All of the songs that I didn’t analyze in Lexicon (analyzed in Rekordbox) made it with all their beatgrid information intact.

Definitely a Lexicon issue. It seems analyzing songs in Lexicon somehow corrupts their information.

I agree that it seems like a Lexicon issue which is why I’ve systematically tried everything to fix this but no luck yet. The weird thing is that with a completely empty RB database and dragging tracks into RB, it still does this. So I’m thinking RB has some kind of setting cached somewhere but I can’t look into what RB does so it’s very difficult to find this one.

I get that, but I paid for a product and now my playlist is completely destroyed. We are talking hundreds of dollars I can not use.

I Appreciate that you are engaging with your customers and are open about the fact that this problem so far is hard to fix.

But when a product is this faulty, and has been since atleast February, and nothing warns anyone about this, then it’s problematic. I downloaded and bought your services in good faith since you got recommended by one of the bigger youtube creators of DJ content and now I can’t even DJ in my own bedroom since my tracks doesn’t wanna sync to my USB and nothing is helping, then it gets frustrating.

1 Like

I understand. There is a workaround, which is to use the old Rekordbox XML method (on the Sync page, you’ll see it in the dropdown). There are also backups of your previous RB database, you can find those here: Lexicon with Rekordbox 6 write support

The XML method is just very painful to use by itself, and very limited. I really hate that Lexicon has this bug and I am trying my best to solve it. Trust me, it is at the top of my priorities right now. Not everyone has this bug though so that also makes it difficult to pinpoint.

And you are entitled to a refund if you want. You can keep an eye on the changelog for this bug and re-join then, no hard feelings :slight_smile:

I running windows, my music library is on external drive. I have this same issue, the Rekordbox 5 xml method is not working for me, and produces the same issue. I specially bought this software for this feature. Please stay on this.


So I had this issue as a new user (Serato was my main system, need to port to RB for CDJs) and had the same issue. Was emailing Chris and he linked me to this thread. I did the XML thing and it worked. BUT I blew away my entire RB database. No big deal for me since I am a Serato user and I had only stuff I exported from Lexicon.

Now, digging into the hidden files I do see multiple RB database backups so perhaps you can pull the one with the date stamp before you did the Lexicon as a backup and do the same. I honestly am a new RB user so not sure if its as easy as that or not.

I just completed a XML sync in Rekordbox, then synced 30 GB of tracks to USB. There were only 2 tracks with corrupt analysis data, which is acceptable. I reanalyzed the 2 tracks and they seemed to sync ok after. I will be testing this USB tonight and report back if there are any further issues.

I remember encountering some issues in Rekordbox using XML after trying direct syncing with the Lexicon beta, so I uninstalled Rekordbox and removed the user files. Then installed a fresh copy of Rekordbox 6.6.3 (which is ok for me since my main system is Traktor).
In Lexicon I used the Rekordbox 5 XML sync. I also reformatted my USB just to be safe.

For those who are interested, in order to delete your user files from Rekordbox please follow the instructions I found here: https://forums.pioneerdj.com/hc/en-us/community/posts/360068123431-How-to-do-a-clean-uninstall-

If you want to FULLY uninstall EVERYTHING, you need to remove these folders after running the uninstaller:

Win 7/8/10:

/Users/yourusername/Library/Application Support/Pioneer/

Note that the “Library” folder is hidden in Mac OS so you need to press Command + Shift + . to show it.

It’s unfortunate that the direct sync in Lexicon doesn’t work when using USB syncing. However since XML syncing seems to work, it’s not a deal-breaker for me. Perhaps it would be prudent to have a warning in the Lexicon app when selecting the Rekordbox 6 sync method so that new users aren’t caught by surprise.


Will clean uninstall of RB make the problem go away? :sweat_smile:

I’m not sure to be honest, would be good to test… It’s not database related as far as I can tell so maybe a config file or something changed in the RB program files… I really don’t know yet, it’s super weird

If someone is tech savvy and not afraid to get their hands dirty on their computer, I would love some more eyes on this bug! Send me a PM and I will send you all the info we have about this issue.

1 Like


I’m a software engineer too, so I know how it goes to have bugs – but this bug ruined one of my live sets completely, I got on stage for sound check and both of my rekordbox USBs were 100% corrupted, and someone else had to play my set.

This is a really really unacceptable state for a paid application to be in, and I’m cancelling my subscription because of it.

I’d recommend you add some sort of VERY LARGE warning or disable this feature completely until you fix it so that you don’t lose any more customers.

1 Like

I’m really sorry to hear that. I wasn’t first aware how serious this bug is but I do see that now. I will add a warning for the time being, fixing it is also still top priority.
You can get a full refund, just PM me your account email. I know that doesn’t bring back your set time, but maybe it makes it a bit less of a shitty situation which it totally is.

Hi all, i am pure Rekordbox user (on MAC) and i have problem during export to USB. I have problem probably last 2 updates of RB (i am not sure) but not too long. I have the same issue in Log file i see problem [4] and after is path to file. Those tracks are not exported due to problem with Track analysis inspite of that track was Analyzed during import and after based on this Error log file i did it separately track by track again but not exported again approx. of 80% from Error file /but some tracks yes/. But long years I did not have this problem. I tried to clear Attributes but not works, no switch off wifi or internet as was described on RB forums, and there is no help as well. So please if any help let us know. thanks

We’re working super hard on fixing this!

Meanwhile you can use the XML method to get your tracks in RB, described here: Rekordbox | Lexicon - DJ Library Management
Follow the Rekordbox 5 steps, they work for Rekordbox 6 too.

You could ask Mix Master G for help, as he seems is very helpful and has written many whitepapers on database conversion. I don’t think he would really care that you are his competition. As he can’t service windows users. Its worth a try. Contact - And The Groove Remains Production Team

Via AppCleaner I have removed everything from Rekordbox and also in the Library folder. Completely re-installed Rekordbox and synchronized via Lexicon and then had all tracks analyzed in Rekeodbox.

Then try to put it on a USB, but no track has been transferred correctly on the USB, the log also points out.

I also tried de RB5 method with a clean RB instal and a fresh USB and here I don’t get any error’s.

We have a test build with a fix for this issue here:

Now this is still a very weird issue, we are getting positive but mixed results. This build does fix what we think is the problem, but RB does some very strange things so you might need to reinstall RB completely if you still get the corrupt error when exporting. Reinstall worked for me, with this new build.