Window went Gray/Blank

Please fill in this bug report template:

Lexicon version: …1.6.4
Operating system (remove one): Windows / Mac
Windows 11
Bug description:
After upgrading I can no longer import without it freezing.
I get a blank screen after some time of trying to import my library from Virtual DJ. I am using the same Virtual DJ version as I did the last time I imported the only thing that changed was Lexicondj

Step by step to reproduce:
Import anything after at least 88% goes to a blank screen. I left it alone for an hour and still blank. Have to FC lexicon. I installed Lexicon then reinstalled and when I first opened it tracks appeared in the library. I tried to import again and it crashed. I’ve delete the library and same result


Blank screen usually indicates a crash due to out of memory, can you check what your memory does in Task Manager when importing?

I opened it today and got the blank screen with a pop up that stated Encountered Error During Launch, please contact support. Error. NOT NULL constraint failed: Playlist.dateModified

I think that’s because it froze during import so now your database is probably broken.
Delete the main.db file to clear it, see Lexicon database & log locations

in the past (still crashed) it was able to get the library, but some of the file locations were broken and didn’t match VDJ. After looking in my VDJ DB file I see there are some of these listed from older versions of VDJ, but don’t show up in my search DB. Not really sure how to remove them so they don’t show up in Lexicondj.
I did record the screen as it imported the tracks and it only go to 88% doesn’t run out of mem and crashes.
After running through a few times, I think the last sync put back some dead links in my VDJ DB which may have caused the issue. I cleaned my search DB in VDJ and I’m running it again. This time it’s taking longer, like it did the first time. I’ll update once it gets done. Right now I’m at 38% and it’s run for 20 Min

Same issue, gets to 88% and crash

Seems memory related though because it has a huge memory spike right before it crashes. But it might be coming across weird tracks that somehow break Lexicon, not sure…

Can you upload your Lexicon database & logs? From the Help menu.

Sure. I’m in the middle of trying again with the virtual folders instead of playlist. I’m thinking it’s getting to the playlist and causing the issue. I had opened the error log and that same playlist date error was there. When end Lexicon via task manager and open it back up, the library is there.

Are you using the latest VDJ? They changed to MyLists instead of Virtual Folders and Playlists, so maybe it is just crashing there.

There is a MyList build for Lexicon here: Virtual DJ: No smart folders after import from SSW - #7 by Christiaan

Okay, they are uploaded. I did notice the last songs I added to my VDJ DB are there. I’m not using the newest version because of that change with the playlist and virtual folders. Waiting to update when I have the proper time to ensure no issues. However, I may do it if I can’t get lexicon to work.

I’m releasing the MyLists update to stable Lexicon today

Logs don’t show anything useful, just that it seems to crash at the same point so could really be related to a specific broken track. Just no idea which one :confused:
You could try importing playlists one by one, see if you can pinpoint it. Not really fun process, but I don’t know what else to try

That’s kinda what I was thinking. Even the error log doesn’t state which one. I started importing some of the playlists and had no issues. I even went back to sync a couple again with no issues. I do remember importing a few months ago and then exporting to Serato with no issues. I’ll continue to try and see what causes the issues. I’ve sat on this program for a long time without actually using it so I’m now wanting to dive in. The other issue I’ve noticed is some tracks won’t get energy, happiness etc levels, even for a very popular track. I’m not sure if i’ts the title information for example (CK EDIT)

Probably better to remove extra info like that, you can do it quickly with recipes

I updated VDJ tried to import some more playlist and got an error. I then deleted my DB (afterbacking up) FC, restarted and I’m still getting the error. TypeError: Cannot read properties undefined (reading ‘ForEach’)

Should be fixed in update later today

Awesome! Guess I updated too much…lol

@Christiaan Is there a way to select all the Playlist when importing with a key stroke? I also don’t see Virtual folds as an option anymore, not a dealbreaker, just trying to figure my new flow

Virtual Folders don’t exist anymore in VDJ, only MyLists now.

If you want to import all playlists, maybe just use Full Import?

They do on mine. Weird.